<?xml version="1.0" encoding="US-ASCII"?>
<!DOCTYPE rfc SYSTEM "rfc2629.dtd">

<!-- For a complete list and description of processing instructions (PIs), 
     please see http://xml.resource.org/authoring/README.html. -->

<?rfc strict="yes" ?>
<?rfc toc="yes" ?>
<?rfc tocdepth="3" ?>
<?rfc symrefs="yes" ?>
<?rfc sortrefs="yes" ?>
<?rfc compact="yes" ?>
<?rfc subcompact="no" ?>

<rfc category="info" docName="draft-ietf-spfbis-experiment-11"
     ipr="trust200902">

<front>
	<title abbrev="SPF/Sender ID Experiments">
		Resolution of The SPF and Sender ID Experiments
	</title>

	<author fullname="Murray S. Kucherawy"
	        initials="M. S." surname="Kucherawy">
		<organization>
			Cloudmark
		</organization>

		<address>
			<postal>
				<street>128 King St., 2nd Floor</street>
				<city>San Francisco</city>
				<region>CA</region>
				<code>94107</code>
				<country>USA</country>
			</postal>

			<phone>+1 415 946 3800</phone>
			<email>superuser@gmail.com</email>
		</address>
	</author>
    
	<date year="2012" />

	<area>Applications</area>
	<workgroup>SPFBIS Working Group</workgroup>

	<keyword>SPF</keyword>
	<keyword>Sender ID</keyword>
	<keyword>authentication</keyword>
	<keyword>authorization</keyword>
	<keyword>email</keyword>

	<abstract>
		<t> In 2006 the IETF published a suite of protocol documents
		    comprising SPF and Sender ID, two proposed email
		    authentication protocols.  Both of these protocols enable
		    one to publish via the Domain Name System a policy
		    declaring which mail servers were authorized to send email
		    on behalf of the domain name being queried.  There was 
		    concern that the two would conflict in some significant
		    operational situations, interfering with message
		    delivery. </t>

		<t> The IESG required the publication of all of these
		    documents (RFC4405, RFC4406, RFC4407, and RFC4408) with
		    Experimental status, and requested that the community
		    observe deployment and operation of the protocols over a
		    period of two years from the date of publication to
		    determine a reasonable path forward. </t>

		<t> After six years, sufficient experience and evidence have
		    been collected that the experiments thus created can be
		    considered concluded.  This document presents those
		    findings. </t>
	</abstract>
</front>

<middle>
	<section anchor="intro" title="Introduction">
		<t> In April 2006, the IETF published
		    the <xref target="SPF"/> and Sender ID email authentication
		    protocols, the latter consisting of three documents
		    (<xref target="SUBMITTER"/>,
		    <xref target="SENDER-ID"/>, and <xref target="PRA"/>).
		    Both of these protocols enable one to publish via the
		    Domain Name System a policy declaring which mail servers
		    are authorized to send email on behalf of the selected
		    domain name. </t>

		<t> Consensus did not clearly support one protocol over the
		    other, and there was significant concern that the two
		    would conflict in some significant operational situations,
		    interfering with message delivery.  The IESG required
		    the publication of all of these documents as Experimental,
		    and requested that the community observe deployment
		    and operation of the protocols over a period of two years
		    from the date of publication in order to determine a
		    reasonable path forward. </t>

		<t> In line with the IESG's request to evaluate after a period
		    of time, this document concludes the experiments by
		    presenting evidence regarding both deployment and 
		    comparative effect of the two protocols.  At the end it
		    presents conclusions based on the data collected. </t>

		<t> It is important to note that this document makes no direct
		    technical comparison of the two protocols in terms of
		    correctness, weaknesses, or use case coverage.  The email
		    community at large has already done that through its
		    deployment choices.  Rather, the analysis presented here
		    merely observes what has been deployed and supported in
		    the time since the protocols were published, and draws
		    conclusions based on those observations. </t>

		<t> The data collected and presented here are presumed to be
		    a reasonable representative view of the global deployment
		    data, which could never itself be fully surveyed within a
		    reasonable period of time. </t>
	</section>

	<section anchor="defs" title="Definitions">
		<t> The term "RRTYPE" is used to refer to a Domain Name
		    System (<xref target="DNS"/>) Resource Record (RR) type.
		    These are always expressed internally in software as
		    numbers, assigned according to the procedures in
		    <xref target="DNS-IANA"/> Assigned RRTYPEs also have
		    names.  The two of interest in this work are the TXT
		    RRTYPE (16) and the SPF RRTYPE (99). </t>
	</section>

	<section anchor="deployment" title="Evidence of Deployment">
		<t> This section presents the collected research done to
		    determine what parts of the two protocol suites are in
		    general use, as well as related issues like
		    <xref target="DNS"/> support. </t>

		<section anchor="deploy_dns" title="DNS Resource Record Types">
			<t> Three large-scale DNS surveys were run that looked
			    for the two supported kinds of RRTYPEs that can
			    contain SPF policy statements.  These surveys
			    selected substantial sets of distinct domain names
			    from email headers and logs over long periods,
			    regardless of whether the DNS data for those
			    domains included A, MX, or any other RRTYPEs.
			    The nameservers for these domains were queried,
			    asking for both of the RRTYPEs that could be used
			    for SPF and/or Sender ID. </t>

			<t> In the tables below, replies were counted only if
			    they included prefixes that indicated the record
			    was intended to be of a form defined in either
			    <xref target="SPF"/> or <xref target="SENDER-ID"/>,
			    though complete syntax validation of the replies
			    was not done.  That is, the records either started
			    "v=spf1" or "spf2.0/", or they were not counted
			    as replies. </t>

			<t> The tables are broken down into three parts:
			    (a) the size of the sample set, (b) a report
			    about RRTYPE use independent of content, and (c)
			    a report about content independent of RRTYPE. </t>

			<t> "SPF+TXT" indicates the count of domains where both
			    types were in use. </t>

			<t><figure>
				<preamble> DNS Survey #1 (Cisco) </preamble>
				<artwork>
  +------------------+-----------+-------+
  | Domains queried  | 1,000,000 |   -   |
  +------------------+-----------+-------+
  | TXT replies      |   397,511 | 39.8% |
  | SPF replies      |     6,627 | &lt;1.0% |
  | SPF+TXT replies  |     6,603 | &lt;1.0% |
  +------------------+-----------+-------+
  | v=spf1 replies   |   395,659 | 39.6% |
  | spf2.0/* replies |     5,291 | &lt;1.0% |
  +------------------+-----------+-------+
				</artwork>
				<postamble> Domains were selected as the top
					million domains as reported by Alexa,
					which monitors browser activity.
				</postamble>
			</figure></t>

			<t><figure>
				<preamble> DNS Survey #2
				           (The Trusted Domain Project) </preamble>
				<artwork>
  +------------------+-----------+-------+
  | Domains queried  |   278,353 |   -   |
  +------------------+-----------+-------+
  | TXT replies      |   156,894 | 56.4% |
  | SPF replies      |     2,876 |  1.0% |
  | SPF+TXT replies  |     2,689 | &lt;1.0% |
  +------------------+-----------+-------+
  | v=spf1 replies   |   149,985 | 53.9% |
  | spf2.0/* replies |     7,285 |  2.7% |
  +------------------+-----------+-------+
				</artwork>
				<postamble> This survey selected its domains
					from data observed in email headers
					and previous SPF and Sender ID
					evaluations, collected from 23
					reporting hosts across a handful of
					unrelated operators over a period of
					22 months. </postamble>
			</figure></t>

			<t> During this second survey, some domains were
			    observed to provide immediate answers for RRTYPE 16
			    queries, but would time out waiting for replies to
			    RRTYPE 99 queries.  For example, it was observed
			    that 4,360 (over 1.6%) distinct domains in the
			    survey returned a result of some kind (a record or
			    an error) for the TXT query in time N, while the
			    SPF query ultimately failed after at least time
			    4N. </t>

			<t><figure>
				<preamble> DNS Survey #3 (Hotmail) </preamble>
				<artwork>
  +------------------+-----------+-------+
  | Domains queried  |   100,000 |   -   |
  +------------------+-----------+-------+
  | TXT replies      |    46,221 | 46.2% |
  | SPF replies      |       954 | &lt;1.0% |
  | SPF+TXT replies  |     1,383 |  1.4% |
  +------------------+-----------+-------+
				</artwork>
				<postamble> Hotmail's domain set was selected
					from live email traffic at the time
					the sample was extracted.  Only
					the RRTYPE portion of the report is
					available. </postamble>
			</figure></t>

			<t> A separate survey was done of queries for RRTYPE
			    16 and RRTYPE 99 records by observing nameserver
			    traffic records.  Only a few queries were ever
			    received for RRTYPE 99 records, and those almost
			    exclusively came from one large email service
			    provider that queried for both RRTYPEs.  The vast
			    majority of other querying agents only ever
			    requested RRTYPE 16. </t>
		</section>

		<section anchor="deploy_impl" title="Implementations">
			<t> It is likely impossible to determine from a survey
			    which Mail Transfer Agents (MTAs) have SPF and/or
			    Sender ID checking enabled at message ingress
			    since it does not appear, for example, in the
			    reply to the EHLO command from extended
			    <xref target="SMTP"/>.  We therefore rely on
			    evidence found via web searches, and observed the
			    following:

			    <list style="symbols">
				<t> A web site <xref target="SID-IMPL"/>
				    dedicated to highlighting Sender ID
				    implementations last updated in late 2007
				    listed 13 commercial implementations,
				    which we assume means they implement the
				    Purported Responsible Address (PRA)
				    checks.  At least one of them is known
				    no longer to be supported by its vendor.
				    There were no free open source
				    implementations listed. </t>

				<t> The <xref target="OPENSPF"/> web site
				    maintains a list of implementations
				    of SPF.  At the time of this document's
				    writing it listed six libraries, 22 MTAs
				    with built-in SPF implementations, and
				    numerous patches for MTAs and mail
				    clients.  The set included a mix of
				    commercial and free open source
				    implementations. </t>
			    </list> </t>
		</section>

		<section anchor="deploy_submitter"
		 title="The SUBMITTER SMTP Extension">
			<t> The PRA is the output of a heuristic that seeks to
			    scan a message header and extract from it the
			    email address most likely to be the one
			    responsible for injection of that message into the
			    mail stream.  The SUBMITTER extension to SMTP is a
			    mechanism to provide an early hint (i.e., as part
			    of the MAIL command in an SMTP session) to the
			    receiving MTA of what the PRA would be on full
			    receipt of the message. </t>

			<t> In a review of numerous MTAs in current or recent
			    use, two (Santronics WinServer and McAfee
			    MxLogic) were found to contain implementations of
			    the SMTP SUBMITTER extension as part of the MTA
			    service, which could act as an enabler to
			    Sender ID. </t>

			<t> An unknown number of SMTP clients implement
			    the SUBMITTER SMTP extension.
			    Although information from MTA logs indicates
			    substantial use of the SMTP extension, it is not
			    possible to determine whether the usage is from
			    multiple instances of the same SMTP client or
			    different SMTP client implementations. </t>

			<t> An active survey of MTAs accessible over the
			    Internet was performed.  The MTAs selected were
			    found by querying for MX and A resource records of
			    a subset of all domains observed by The Trusted
			    Domain Project's data collection system in the
			    preceding 20 months.  The results were as follows:

			   <figure>
				<preamble> SUBMITTER Survey
					(The Trusted Domain Project) </preamble>
				<artwork>
  +-------------------+-----------+-------+
  | MTAs selected     |   484,980 |   -   |
  | MTAs responding   |   371,779 | 76.7% |
  | SUBMITTER enabled |    17,425 |  4.7% |
  | MXLogic banner    |    16,914 |  4.6% |
  +-------------------+-----------+-------+
				</artwork>
				<postamble> Note: The bottom two rows indicate
					the percentage of responding MTAs
					with the stated property, not the
					percentage of selected
					MTAs. </postamble>
			</figure></t>

			<t> Based on the SMTP banner presented upon
			    connection, the entire set of SUBMITTER-enabled
			    MTAs consisted of the two found during the review
			    (above) and a third whose identity could not be
			    positively determined. </t>

			<t> Of those few responding MTAs advertising the
			    SUBMITTER SMTP extension, 97% were different
			    instances of one MTA.  The service operating that
			    MTA (MXLogic, a division of McAfee) reported that
			    about 11% of all observed SMTP sessions involved
			    SMTP clients that make use of the SUBMITTER
			    extension.  Note that this represents about 11%
			    of the clients of 4.6% of the responding MTAs in
			    the survey. </t>
		</section>
	</section>

	<section anchor="deviation" title="Evidence of Differences">
		<t> Separate surveys from Hotmail and The Trusted Domain
		    Project compared the cases where the PRA (used
		    by Sender ID) and the RFC5321.MailFrom address (used by
		    SPF) differed.  The results of these tests showed that
		    at least 50% of the time the two addresses were the
		    same, but beyond that the percentage varied substantially
		    from one sampling location to the next due to the nature
		    of the mail streams they each receive. </t>

		<t> Further, The Trusted Domain Project analyzed
		    approximately 150,000 messages and found that
		    in more than 95% of those cases, Sender ID and SPF reach
		    the same conclusion about a message, meaning either both
		    protocols return a "pass" result or both return a "fail"
		    result.  Note that this does not include an evaluation of
		    whether "fail" meant spam or other abusive mail was thus
		    detected or that "pass" mail is good mail; it is merely a
		    measure of how often the two protocols concurred.  The data
		    set yielding this response could not further characterize
		    the cases in which the answers differed. </t>

		<t> A second analysis of the same nature by Hotmail
		    found that the two protocols yielded the same result
		    approximately 80% of the time when evaluated across
		    billions of messages. </t>

		<t> Anecdotally, the differences in conclusions have not been
		    noted as causing significant operational problems by the
		    email-receiving community. </t>
	</section>

	<section anchor="analysis" title="Analysis">
		<t> Given the six years that have passed since the publication
		    of the Experimental RFCs, and the evidence reported in
		    the earlier sections of this document, the following
		    analysis appears to be supported:

		    <list style="numbers">
			<t> There has not been substantial adoption of the
			    RRTYPE 99 (SPF) DNS resource record.  In all
			    large-scale surveys performed for this work, fewer
			    than 2% of responding domains published RRTYPE 99
			    records, and almost no clients requested them. </t>

			<t> Of the DNS resource records retrieved, fewer than
			    3% included specific requests for processing of
			    messages using the PRA algorithm, which is an
			    essential part of Sender ID. </t>

			<t> Although the two protocols often used different
			    email address fields as the subject being
			    evaluated, no data collected showed any substantial
			    operational benefit, in terms of improved accuracy,
			    to using one mechanism over the other. </t>

			<t> A review of known implementations shows significant
			    support for both protocols, though there were
			    more implementations in support of SPF than of
			    Sender ID.  Further, the SPF implementations
			    showed better upkeep and current interest than
			    the Sender ID implemenations. </t>

			<t> A survey of running MTAs shows fewer than 5% of
			    them advertised the SUBMITTER extension, which
			    is a Sender ID enabler.  Only three implementations
			    of it were found. </t>

			<t> There remain obstacles to deployment of protocols
			    that use DNS RRTYPEs other than the most common
			    ones, including firewalls and DNS servers that
			    block or discard requests for unknown RRTYPEs.
			    Further, few if any web-based DNS configuration
			    tools offer support for RRTYPE 99 records. </t>
		    </list> </t>
	</section>

	<section anchor="conclusions" title="Conclusions">
		<t> In light of the analysis in the previous
		    section, the following conclusions are supported:

			<list style="numbers">
				<t> The experiments comprising the series
				    of RFCs defining the SUBMITTER SMTP
				    extension (RFC4405), the Sender ID
				    mechanism (RFC4406), the Purported
				    Responsible address algorithm (RFC4407),
				    and SPF (RFC4408), should be considered
				    concluded. </t>

				<t> The absence of significant adoption
				    of the RRTYPE 99 DNS Resource Record
				    suggests that it has not attracted enough
				    support to be useful. </t>

				<t> Unavailability of software implementing
				    the protocols was not a gating factor in
				    terms of the selection of which to
				    use. </t>

				<t> The absence of significant adoption of
				    the <xref target="SUBMITTER"/> extension,
				    <xref target="SENDER-ID"/>, and
				    <xref target="PRA"/>, indicates that there
				    is not a strong community deploying and
				    using these protocols. </t>

				<t> <xref target="SPF"/> has widespread
				    implementation and deployment, comparable
				    to that of many standards track
				    protocols. </t>
			</list> </t>

		<t> <xref target="rrtype"/> is offered as a cautionary review
		    of problems that affected the process of developing SPF
		    and Sender ID in terms of their use of the DNS. </t>
	</section>

	<section anchor="sec_considerations" title="Security Considerations">
		<t> This document contains information for the community,
		    akin to an implementation report, and does not introduce
		    any new security concerns. </t>
	</section>

	<section anchor="iana_considerations" title="IANA Considerations">
		<t> This document presents no actions for IANA.
		    [RFC Editor: Please remove this section prior to
		    publication.] </t>
	</section>
</middle>

<back>
	<references title="Normative References">
		<reference anchor="DNS">
			<front>
				<title>
					Domain names - implementation and
					specification
				</title>

				<author initials="P." surname="Mockapetris"
				        fullname="P. Mockapetris">
					<organization>USC/ISI</organization>
				</author>

				<date year="1987" day="1" month="November"/>
			</front>

			<seriesInfo name="STD" value="13"/>

			<seriesInfo name="RFC" value="1035"/>
		</reference>

		<reference anchor="PRA">
			<front>
				<title>
					Purported Responsible Address in
					E-Mail Messages
				</title>

				<author initials="J." surname="Lyon"
				        fullname="J. Lyon">
					<organization>
						Microsoft Corp.
					</organization>
				</author>

				<date year="2006" month="April"/>
			</front>

			<seriesInfo name="RFC" value="4407"/>
		</reference>

		<reference anchor="SENDER-ID">
			<front>
				<title>
					Sender ID: Authenticating E-Mail
				</title>

				<author initials="J." surname="Lyon"
				        fullname="J. Lyon">
					<organization>
						Microsoft Corp.
					</organization>
				</author>

				<author initials="M." surname="Wong"
				        fullname="M. Wong">
					<organization>
						pobox.com
					</organization>
				</author>

				<date year="2006" month="April"/>
			</front>

			<seriesInfo name="RFC" value="4406"/>
		</reference>

		<reference anchor="SPF">
			<front>
				<title>
					Sender Policy Framework (SPF) for
					Authorizing Use of Domains in E-Mail,
					Version 1
				</title>

				<author initials="M." surname="Wong"
				        fullname="M. Wong">
				</author>

				<author initials="W." surname="Schlitt"
				        fullname="W. Schlitt">
				</author>

				<date year="2006" month="April"/>
			</front>

			<seriesInfo name="RFC" value="4408"/>
		</reference>

		<reference anchor="SUBMITTER">
			<front>
				<title>
					SMTP Service Extension for Indicating
					the Responsible Submitter of an E-Mail
					Message
				</title>

				<author initials="E." surname="Allman"
				        fullname="E. Allman">
					<organization>
						Sendmail, Inc.
					</organization>
				</author>

				<author initials="H." surname="Katz"
				        fullname="H. Katz">
					<organization>
						Microsoft Corp.
					</organization>
				</author>

				<date year="2006" month="April"/>
			</front>

			<seriesInfo name="RFC" value="4405"/>
		</reference>
	</references>

	<references title="Informative References">
		<reference anchor="DNS-EXPAND">
			<front>
				<title>Design Choices When Expanding
				       the DNS</title>

				<author initials="P." surname="Faltstrom"
					fullname="P. Faltstrom">
					<organization/>
				</author>

				<author initials="R." surname="Austein"
					fullname="R. Austein">
					<organization/>
				</author>

				<author initials="P." surname="Koch"
					fullname="P. Koch">
					<organization/>
				</author>

				<date year="2009" month="April"/>
			</front>

			<seriesInfo name="RFC" value="5507"/>
		</reference>

		<reference anchor="DNS-IANA">
			<front>
				<title>Domain Name System (DNS) IANA
					Considerations</title>

				<author initials="D." surname="Eastlake 3rd"
					fullname="D. Eastlake 3rd">
					<organization> Huawei
						</organization>
				</author>

				<date year="2011" month="March"/>

			</front>

			<seriesInfo name="RFC" value="6195"/>
		</reference>

		<reference anchor="OPENSPF" target="http://www.openspf.net">
			<front>
				<title>
					Sender Policy Framework: Project
					Overview
				</title>

				<author fullname="The SPF Council">
				</author>
			</front>
		</reference>

		<reference anchor="SID-IMPL"
		           target="http://www.microsoft.com/mscorp/safety/technologies/senderid/support.mspx">
			<front>
				<title>
					Sender ID Framework Industry Support
					and Solutions
				</title>

				<author fullname="Microsoft">
				</author>

				<date year="2007" month="October"/>
			</front>
		</reference>

		<reference anchor="SMTP">
			<front>
				<title>Simple Mail Transfer Protocol</title>

				<author initials="J." surname="Klensin"
					fullname="J. Klensin">
					<organization/>
				</author>

				<date year="2008" month="October"/>

			</front>

			<seriesInfo name="RFC" value="5321"/>
		</reference>
	</references>

	<section anchor="rrtype" title="Background on the RRTYPE Issue">
		<t> SPF was originally created by a community of interested
		    developers outside the IETF, with the intent of bringing
		    it to the IETF for standardization after it had become
		    relatively mature and ready for the IETF standards track
		    process. </t>

		<t> At the time of SPF's initial development, the prospect of
		    getting an RRTYPE allocated for SPF
		    was not seriously considered, partly because doing so had
		    high barriers to entry.  As a result, at the time it
		    was brought to the IETF for development and publication,
		    there was already a substantial and growing installed base
		    that had SPF running using TXT RRs.  Eventually the
		    application was made for the new RRTYPE as a result of
		    pressure from the DNS experts in the community, who
		    insisted upon doing so as the preferred path toward using
		    the DNS for storing such things as policy data. </t>

		<t> Later, after RRTYPE 99 was assigned (long after IESG
		    approval of <xref target="SPF"/>, in fact), a plan was put
		    into place to effect a gradual transition to using RRTYPE
		    99 instead of using RRTYPE 16.  This plan failed to take
		    effect for four primary reasons:

		    <list style="numbers">
			<t> there was hesitation to make the transition because
			    existing nameservers (and, in fact, DNS-aware
			    firewalls) would drop or reject requests for
			    unknown RRTYPEs (see
			    <xref target="deployment"/> for evidence of
			    this), which means successful rollout of a new
			    RRtype is contingent upon widespread adoption
			    of updated nameservers and resolver functions; </t>

			<t> many DNS provisioning tools (e.g., web interfaces
			    to controlling DNS zone data) were, and still are,
			    typically lethargic about adding support for
			    new RRTYPEs; </t>

			<t> the substantial deployed base was already using
			    RRTYPE 16, and it was working just fine, leading
			    to inertia; </t>

			<t> <xref target="SPF"/> itself included a faulty
			    transition plan, likely because of the late
			    addition of a requirement to develop one: It said
			    a server SHOULD publish both RRTYPEs and MUST
			    publish at least one, while a client can query
			    either or both, which means both can claim to be
			    fully compliant while failing utterly to
			    interoperate.  Publication occurred without
			    proper IETF review, so this was not detected prior
			    to publication. </t>
		    </list> </t>

		<t> It is likely that this will happen again if the bar
		    to creating new RRTYPEs even for experimental
		    development purposes is not lowered, and handling of
		    unknown RRTYPEs in software becomes generally more
		    graceful.  Also important in this regard is encouragement
		    of support for new RRTYPEs in DNS record provisioning
		    tools. </t>

		<t> Fortunately in the intervening time, the requirements for
		    new RRTYPE assignments was changed to be less stringent
		    (see <xref target="DNS-IANA"/>).  Also, the
		    publication of <xref target="DNS-EXPAND"/> has provided
		    some useful guidance in this regard.  However, there
		    is still a common perception that adding new types of
		    data to the DNS will face resistance due to the lack of
		    appropriate software support. </t>

		<t> There are DNS experts within the community that will
		    undoubtedly point to DNS servers and firewalls that
		    mistreat queries for unknown RRTYPEs, and to overly
		    simplistic provisioning tools, and claim they
		    are broken as a way of answering these concerns.  This
		    is undoubtedly correct, but the reality is that they are
		    among us and likely will be for some time, and this
		    needs to be considered as new protocols and IETF procedures
		    are developed. </t>
	</section>

	<section anchor="acks" title="Acknowledgments">
		<t> The following provided operational data that contributed to
		    the evidence presented above:

		    <list style="hanging">
			<t hangText="Cisco:"> contributed data about
				observed Sender ID and SPF records in the DNS
				for a large number of domains
				(DNS survey #1)</t>

			<t hangText="Hotmail:"> contributed data about the
				difference between RFC5321.MailFrom and
				RFC5322.From domains across large mail
				volumes, and a survey of DNS replies observed
				in response to incoming mail traffic
				(DNS survey #3) </t>

			<t hangText="John Levine:"> conducted a survey
				of DNS server logs to evaluate SPF-related
				query traffic </t>

			<t hangText="McAfee:"> provided details about their
				SUBMITTER implementation and usage
				statistics </t>

			<t hangText="Santronics:"> contributed data about the
				use of the SUBMITTER extension in 
				aggregate SMTP client traffic </t>

			<t hangText="The Trusted Domain Project:">
				contributed data about the difference
				between Sender ID and SPF results,
				conducted one of the detailed
				TXT/SPF RRTYPE surveys including collecting
				timing data (DNS survey #2), and conducted the
				MTA SUBMITTER survey </t>
		    </list> </t>

		<t> The author would also like to thank the following for
		    their contributions to the development of the text in
		    this document:
		    Dave Crocker,
		    Scott Kitterman,
		    Barry Leiba,
		    John Leslie,
		    John Levine,
		    Hector Santos,
		    and
		    Alessandro Vesely. </t>
	</section>
</back>

</rfc>
