<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE rfc SYSTEM "rfc2629.dtd" [
    <!ENTITY rfc2119 PUBLIC '' 
      'http://xml.resource.org/public/rfc/bibxml/reference.RFC.2119.xml'>
]>

<rfc category="info" ipr="full3978" docName="draft-ietf-v6ops-rfc3330-for-ipv6-04.txt">

<?xml-stylesheet type='text/xsl' href='rfc2629.xslt' ?>

<?rfc toc="yes" ?>
<?rfc symrefs="yes" ?>
<?rfc sortrefs="yes"?>
<?rfc iprnotified="no" ?>
<?rfc strict="yes" ?>
<?rfc compact="yes" ?>

<front>
<title>Special-Use IPv6 Addresses</title>
<author initials='M.' surname="Blanchet" fullname='Marc Blanchet'>
  <organization>Viagenie</organization>
  <address>
    <postal>
      <street>2600 boul. Laurier, suite 625</street>
      <city>Quebec</city>
      <region>QC</region>
      <code>G1V 4W5</code>
      <country>Canada</country>
    </postal>
    <email>Marc.Blanchet@viagenie.ca</email>
    <uri>http://www.viagenie.ca</uri>
  </address>
</author>
<date month="January" year="2008"/>
<abstract>
<t>This document describes the global and other specialized IPv6 address blocks. It does not address IPv6 address space assigned to operators and users through the Regional Internet Registries. These descriptions are useful for route and IP filtering, for documentation and other purposes.  </t>
</abstract>
</front>
<middle>
  <section title="Introduction">
<t>This document describes the global and other specialized IPv6 address blocks.It does not address IPv6 address space assigned to operators and users through the Regional Internet Registries. These descriptions are useful for route and IP filtering, for documentation and other purposes.</t>
<t>The document is structured by address types. The document format is similar to <xref target="RFC3330"/>.</t>
<t>Some tips about filtering are given, but are not mandatory to implement.</t>
<t>The addresses listed in this document must not be hard coded into implementations.</t>
  </section>
  <section title="Address Blocks">
    <section title="Node-scoped Unicast">
      <t>::1/128 is the loopback address <xref target="RFC4291"/>.</t>
      <t>::/128 is the unspecified address <xref target="RFC4291"/>.</t>
      <t>Addresses within this block should not appear on the public Internet.</t>
    </section>
    <section title="IPv4-Mapped Addresses">
      <t>::FFFF:0:0/96 are the IPv4-mapped addresses <xref target="RFC4291"/>. Addresses within this block should not appear on the public Internet.</t>
    </section>
    <section title="IPv4-compatible Addresses">
<t>::ipv4-address/96 are the IPv4-compatible addresses <xref target="RFC4291"/>. These addresses are deprecated and should not appear on the public Internet.</t>
    </section>
    <section title="Link-scoped Unicast">
      <t>fe80::/10 are the link-local unicast <xref target="RFC4291"/> addresses. Addresses within this block should not appear on the public Internet.</t>
    </section>
    <section title="Unique-Local">
       <t>fc00::/7 are the unique-local addresses <xref target="RFC4193"/>. Addresses within this block should not appear by default on the public Internet. Procedure for advertising these addresses are further described in <xref target="RFC4193"/>.</t>
     </section>
      <section title="Documentation Prefix">
         <t>The 2001:db8::/32 are the documentation addresses <xref target="RFC3849"/>. They are used for documentation purposes such as user manuals, RFCs, etc.  Addresses within this block should not appear on the public Internet.</t>
       </section>
       <section title="6to4">
         <t>2002::/16 are the 6to4 addresses <xref target="RFC3056"/>. The 6to4 addresses may be advertised when the site is running a 6to4 relay or offering a 6to4 transit service. However, the provider of this service should be aware of the implications of running such service<xref target="RFC3964"/>, which include some specific filtering rules for 6to4. IPv4 addresses disallowed in 6to4 prefixes are listed in section 5.3.1 of <xref target="RFC3964"/>.</t>
       </section>
       <section title="Teredo">
         <t>2001::/32 are the Teredo addresses <xref target="RFC4380"/>. The Teredo addresses may be advertised when the site is running a Teredo relay or offering a Teredo transit service.</t>
       </section>
       <section title="6bone">
<t>5f00::/8 were the addresses of the first instance of the 6bone experimental network <xref target="RFC1897"/>.</t>
<t>3ffe::/16 were the addresses of the second instance of the 6bone experimental network <xref target="RFC2471"/>.</t>
<t>Both 5f00::/8 and 3ffe::/16 were returned to IANA <xref target="RFC3701"/>. These addresses are subject to future allocation, similar to current unallocated address space. Addresses within this block should not appear on the public Internet until they are reallocated.</t>
       </section>
       <section title="ORCHID">
<t>2001:10::/28 are ORCHID addresses <xref target="RFC4843"/>. These addresses are used as identifiers and are not routable at the IP layer. Addresses within this block should not appear on the public Internet. </t>
       </section>
     <section title="Default Route">
       <t>::/0 is the default unicast route address.</t> 
     </section>
     <section title="IANA Special Purpose IPv6 Address Block">
     <t>An IANA registry (iana-ipv6-special-registry) is set <xref target="RFC4773"/> for Special Purpose IPv6 address blocks assignments used for experiments and other purposes. Addresses within this registry should be reviewed for Internet routing considerations. </t>
     </section>
     <section title="Multicast">
       <t>ff00::/8 are multicast addresses <xref target="RFC4291"/>. They have a 4 bits scope in the address field where only some value are of global scope <xref target="RFC4291"/>. Only addresses with global scope in this block may appear on the public Internet.</t>
       <t>Multicast routes must not appear in unicast routing tables.</t>
     </section>
  </section>
  <section title="Security Considerations">
     <t>This document lists addresses and guidelines associated with them. The guidelines should improve the security of networks by the filtering of invalid routing prefixes.</t>
  </section>
  <section title="IANA Considerations">
<t>To ensure consistency and to provide cross-referencing for the benefit of the community, IANA is requested to insert the following paragraph in the header of the iana-ipv6-special registry.</t>
<t>
"Other special IPv6 addresses requiring specific considerations for global routing are listed in RFCXXXX."</t>

<t>NOTE TO RFC EDITOR and IANA: replace RFCXXXX by the assigned RFC number of this document.</t>
  </section>
  <section title="Acknowledgements">
     <t>Florent Parent, Pekka Savola, Tim Chown, Alain Baudot, Stig Venaas, Vincent Jardin, Olaf Bonness, David Green, Gunter Van de Velde, Michael Barnes, Fred Baker, Edward Lewis, Marla Azinger, Brian Carpenter, Mark Smith, Kevin Loch, Alain Durand, Jim Bound, Peter Sherbin, Bob Hinden, Gert Doering, Niall O'Reilly, Mark Townsley and Jari Arkko have provided input and suggestions to this document.</t>
  </section>
</middle>
<back>
  <references title="Normative References">
    <?rfc include="reference.RFC.4291" ?>
  </references>
  <references title="Informative References">
    <?rfc include="reference.RFC.1897" ?>
    <?rfc include="reference.RFC.2471" ?>
    <?rfc include="reference.RFC.3056" ?>
    <?rfc include="reference.RFC.3330" ?>
    <?rfc include="reference.RFC.3701" ?>
    <?rfc include="reference.RFC.3849" ?>
    <?rfc include="reference.RFC.3964" ?>
    <?rfc include="reference.RFC.4193" ?>
    <?rfc include="reference.RFC.4380" ?>
    <?rfc include="reference.RFC.4773" ?>
    <?rfc include="reference.RFC.4843" ?>
  </references>
</back>
</rfc>
