<?xml version="1.0" encoding="US-ASCII"?>
<!DOCTYPE rfc SYSTEM "rfc2629.dtd" [
<!ENTITY RFC1034 SYSTEM "http://xml.resource.org/public/rfc/bibxml/reference.RFC.1034.xml">
<!ENTITY RFC1035 SYSTEM "http://xml.resource.org/public/rfc/bibxml/reference.RFC.1035.xml">
<!ENTITY RFC5890 SYSTEM "http://xml.resource.org/public/rfc/bibxml/reference.RFC.5890.xml">
<!ENTITY RFC6672 SYSTEM "http://xml.resource.org/public/rfc/bibxml/reference.RFC.6672.xml">
]>
<?xml-stylesheet type='text/xsl' href='rfc2629.xslt' ?>
<?rfc compact="yes" ?>
<?rfc subcompact="no" ?>
<?rfc toc="yes" ?>
<?rfc tocindent="yes" ?>
<?rfc tocdepth="2" ?>
<?rfc symrefs="yes" ?>
<?rfc sortrefs="yes"?>
<?rfc iprnotified="no" ?>

<rfc category="info" docName="draft-levine-tld-variant-00" ipr="trust200902">
   <front>
      <title abbrev="TLD variants">Variant Names in Top Level Domains</title>

      <author fullname="John Levine" initials="J." surname="Levine">
	 <organization>Taughannock Networks</organization>

	 <address>
	    <postal>
	       <street>PO Box 727</street>
	       <city>Trumansburg</city>
	       <code>14886</code>
	       <region>NY</region>
	    </postal>
	    <phone>+1 831 480 2300</phone>
	    <email>standards@taugh.com</email>
	    <uri>http://jl.ly</uri>
	 </address>
      </author>
      
      <author fullname="Paul Hoffman" initials="P." surname="Hoffman">
	 <organization>VPN Consortium</organization>
	 <address>
	    <email>paul.hoffman@vpnc.org></email>
	 </address>
      </author>
      
      <date month="October" year="2012" />

      <area>Applications</area>
      
      <keyword>DNS</keyword>
      <keyword>variants</keyword>
      <keyword>TLDs</keyword>
      
      <abstract>
	 <t>IDNA <xref target="RFC5890" /> provides a method to map a subset
	    of names written in Unicode into the DNS.
	    Some languages allow a particular name to be written in multiple ways that are
	    represented differently in IDNA, known as "variants".
	    We survey the approaches that ICANN-managed top level domains have taken
	    to the registration and provisioning of variant names.	  
	 </t>
      </abstract>
   </front>
   
   <middle>
      <section title="Introduction">
	 <t>
	    IDNA <xref target="RFC5890" /> provides a method to map a subset
	    of names written in Unicode into <xref target="RFC1035">the DNS</xref>.
	    Some languages allow a particular name to be written in multiple ways that are
	    represented differently in IDNA, known as "variants".
	    In some cases, the variants are multiple equally valid ways of writing the same
	    thing, such as traditional and simplified Chinese characters.
	    Some languages written in Latin characters with accents and diacritical marks
	    allow the marks to be omitted in some situations, such as French which often
	    omits accents on capital letters.
	    Due to the difficulty of representing accented characters in ASCII systems,
	    many users have informally used unaccented characters in DNS names, even when
	    they are not linguistically equivalent to the accented versions.
	 </t>
	 <t>
	    The proper handing of variant names has been a topic of extensive debate and
	    research, with little consensus reached on how to handle them, or even what
	    characters are variants of each other.
	    Many people would like variant names to behave "the same", for a diverse range
	    of meanings of "same."  In some cases it is a textual similarity, such as
	    variants having corresponding DNS records, in some it is functional similarity,
	    such as variant names resolving to the same web server, or the same page in a
	    web server, while in others it is user experience similarity, such as names
	    resolving to web pages which while not identical are perceived by human
	    users as equivalent.
	 </t>
	 <t>
	    This document provides a snapshot of variant handling in the top level domains
	    managed by ICANN, so called gTLDs (generic TLDs) and sTLDs (sponsored TLDs),
	    as of late 2012.
	    We chose those domains because ICANN requires each TLD to describe its IDN and
	    variant practices, and the TLD zone files are available for inspection, to
	    verify what actually goes into the zones.
	 </t>
      </section>
      
      <section title="Terminology">
	 <t>We use some terminology that has become fairly well agreed when discussing variant names.</t>
	 <t><list style='hanging'>
	    
	    <t hangText="Bundle:">A set of names that are considered equivalent.  The rules for what constitutes
	       a bundle vary among languages, and for the same language can vary among TLDs.</t>
	    
	    <t hangText="Preferred variant:">In a bundle, one variant is identified as preferred.
	       Typically it is the variant that best matches the way that words are written in natural language.
	       Preferred variants are both language and country specific.
	       For example, in some Chinese-speaking
	       countries, the preferred variant is simplified characters, while in others it is traditional characters.
	    </t>
	    
	    <t hangText="Blocking:">When one name (or sometimes several names) in a bundle are registered in a TLD,
	       the rest of the names in the bundle are often blocked, meaning that nobody can register them, or sometimes
	       that nobody other than the same registrant can register them.</t>
	    
	    <t hangText="Parallel NS:">Multiple names in a bundle are provisioned in the TLD with identical NS records,
	       so they all are handled by the same name servers.
	    </t>
	    
	    <t hangText="DNAME:">The <xref target="RFC6672">DNAME</xref> DNS record creates a shadow tree of DNS records,
	       roughly as though there were a CNAME in the shadow tree pointing to each name in the target tree.
	       DNAMEs have been used both as second-level names, to provide resolution for several names in a bundle,
	       and as first-level names, to provide resolution for every name under a TLD.
	    </t>
	    
	    </list></t>
      </section>
      
      <section title="Base documents">
	 <t>ICANN has published a variety of documents on variant management.
	    The most important are the "Guidelines for the Implementation of Internationalized Domain Names"
	    issued in <xref target="G1">Version 1.0</xref> and <xref target="G3">Version 3.0</xref>.
	 </t>
	 <t>TLDs are supposed to register an IDN practices document with IANA for each language in which the TLD
	    accepts IDN registrations, to be entered in <xref target="IANAIDN">an IANA registry</xref>.
	    The practices document lists the Unicode characters allowed in names in the language, which characters
	    are considered equivalent, and which of an equivalent group is preferred.
	    Some TLDs have been more diligent than others at keeping the registry up to date.
	 </t>
	 <t>
	    Some of the <xref target="ICANNAGREE">ICANN agreements with each TLD</xref>
	    describe the TLD's IDN practices, but most don't.
	 </t>
      </section>
      
      <section title="Domain practices">
	 <section title="AERO">
	    <t>The .AERO TLD has no IDNs, and no rules or practices for them.</t>
	 </section>
	 
	 <section title="ASIA">
	    <t>The .ASIA domain accepts registrations in many Asian languages.
	       They have IANA tables for Japanese, Korean, and Chinese.
	       The IANA tables refer to their <xref target="ASIACJK">CJK IDN policies</xref>,
	       which say that applied-for and preferred IDN variants are "active and included in the zone."
	       No IDN publication mechanism is described in the documentation, but
	       from inspection of the zonefile, it is clear that the zone is using parallel NS for variants.
	    </t>
	 </section>
	 
	 <section title="BIZ">
	    <t>ICANN gave the registry (Neustar)
	       non-specific permission to register in <xref target="TWOMEY04A">a letter in 2004</xref>.
	       The IDN rules were apparently discussed with ICANN, but not defined;
	       see <xref target="ICANNBIZ9">Appendix 9 of the registry agreement</xref>.
	    </t>
	    <t>They have about a dozen IANA tables.
	       No IDN publication mechanism is described, but from inspection it appears that
	       variants are blocked.
	    </t>
	 </section>
	 
	 <section title="CAT">
	    <t>
	       The IDN rules are described in <xref target="ICANNCATS">Appendix S Part VII.2</xref> of the ICANN agreement.
	       "Registry will take a very cautious approach in its IDN offerings.
	       IDNs will be bundled with the equivalent ASCII domains."
	       The only language is Catalan.
	       No IDN publication mechanism is described.
	    </t>
	    <t>
	       Bundles consist of names with accented and unaccented vowels, and "ll" and the Catalan letter
	       written as two L's with a dot in between.
	    </t>
	    <t>When a registrant registers an IDN, the registry also includes the ASCII version.
	       From inspection of the zonefile, the ASCII version is provisioned with NS, and the
	       IDN is a DNAME pointing to the ASCII version.
	    </t>
	 </section>
	 
	 <section title="COM">
	    
	    <t>ICANN and Verisign have extensive correspondence about IDNs and variants, at
	       including letters from <xref target="TURNER03">Ben Turner</xref> and
	       <xref target="LEWIS03">Ed Lewis</xref>.
	    </t>
	    <t>The IANA registry has tables for several dozen languages, including archaic languages such
	       as hieroglyphics and Aramaic.
	       Verisign publishes documents describing 
	       <xref target="VRSNLANG">Scripts and Languages</xref>,
	       <xref target="VRSNCHAR">Character Variants</xref>,
	       <xref target="VRSNRULES">Registration Rules</xref>, and
	       <xref target="VRSNADDL">additional registration logic</xref>.
	    </t>
	    <t>In Chinese, variants are blocked (see <xref target="VRSNADDL" />.)
	       In other languages there appears to be no bundling or blocking.
	    </t>
	 </section>
	 
	 <section title="COOP">
	    <t>The .COOP TLD has no IDNs, and no rules or practices for them.</t>
	 </section>
	 
	 <section title="INFO">
	    <t>The IANA registry has tables for Danish, Hungarian, Lithuanian, Latvian, and Swedish from 2005.
	       The domain also has names in Greek, Russian, Arabic, and other languages but no IANA tables.</t>
	    <t>The registry agreement <xref target="ICANNINFO9">Appendix 9</xref> refers to
	       <xref target="TWOMEY03">a 2003 letter from Paul Twomey</xref>
	       that refers to blocking variants.</t>
	 </section>
	 
	 <section title="JOBS">
	    <t>The .JOBS TLD has no IDNs, and no rules or practices for them.</t>
	 </section>
	 
	 <section title="MOBI">
	    <t>The zone file has about 22,000 IDNs.
	       The domain has no tables at IANA.
	       The registry agreement <xref target="ICANNMOBIS">Appendix S</xref>
	       says that IDNs are provisioned according to <xref target="G1" />.
	    </t>
	 </section>
	 
	 <section title="MUSEUM">
	    <t>The zone file has many of IDNs, spot checks find that many lame or dead.
	       A <xref target="TWOMEY04">2004 letter from Paul Twomey</xref>
	       refers to <xref target="G1" />.
	    </t>
	    <t>The registry has a <xref target="MUSEUMIDN">detailed policy page</xref>.
	       IDNs are accepted in Latin and Hebrew scripts, with plans for Arabic, Chinese, Japanese, Korean,
	       Cyrillic, and Greek.
	       They do no bundling or blocking, but names that may be confusable due to visual similarity are
	       not allowed, apparently determined by manual inspection, which is practical
	       due to the very small size of the domain.
	    </t>
	 </section>
	 
	 <section title="NAME">
	    <t>The .NAME domain is 
	       now owned by Verisign, and has same long list of scripts as .COM and .NET.	
	       http://www.icann.org/correspondence/twomey-to-rasmussen-15aug04.pdf
	       refers to Appendix K of the agreement, but appendices are numbered.
	       <xref target="ICANNNAME11">Appendix 11</xref> is about restrictions on names, but says nothing about IDNs.
	       The Letter above refers to <xref target="G1" />.
	    </t>
	 </section>
	 
	 <section title="NET">
	    <t>The domain is managed the same as .COM.
	    </t>
	 </section>
	 
	 <section title="ORG">
	    <t>A <xref target="TWOMEY03A">2003 letter from Paul Twomey</xref>
	       refers to <xref target="G1" />.
	       The registry has a <xref target="PIRIDN">list of IDN languages</xref>,
	       all written in Latin script.
	       The practices for some but not all are registered with IANA,
	       Since none of the languages do bundling, there is presumably no blocking.
	    </t>
	 </section>
	 
	 <section title="POST">
	    <t>The .POST TLD appears to have no registrations at all yet.</t>
	 </section>
	 
	 <section title="PRO">
	    <t>The .PRO TLD has no IDNs, and no rules or practices for them.</t>
	 </section>
	 
	 <section title="TEL">
	    <t>The zone has many IDNs.
	       It is probably operating according to <xref target="TWOMEY04A">a 2004 letter
		  from Paul Twomey</xref> which didn not mention specific TLDs.
	       Its <xref target="TELPOLICY">policy page</xref> has links to IDN
	       practices for 17 languages, all but one of which are registered with IANA.
	       None of the Latin scripts do bundling or blocking.
	       The Japanese practices say that variants are blocked.
	       The Chinese table says: 
	    </t>
	    <t>
	       <list style='empty'>
		  <t>
		     Therefore, in addition to the blocking mechanism, bundling is also implemented for the
		     Chinese language IDNs. When registering a Chinese language IDN (primary domain
		     name) up to two additional variant domain names will be automatically registered. The
		     first variant will consist entirely of simplified Chinese characters that correspond to those
		     comprising the primary domain name. The second variant will consist exclusively of
		     traditional Chinese characters that correspond to those comprising the primary domain
		     name.
		  </t>
		  <t>
		     The primary domain name together with the requested variants constitutes a bundle on
		     which all operations are atomic. For example, if the registrant adds a name server to the
		     primary domain name, all names in the bundle will be associated with that new name
		     server.
		  </t>
	       </list>
	    </t>
	    <t>
	       The zone has no DNAME records, so the second paragraph strongly suggests parallel NS.
	    </t>
	    <t>The .TEL TLD, intended as an online directory, does not allow registrants to enter arbitrary
	       RR's in the zone.
	       Nearly all names have NS records pointing to Telnic's own name servers.
	       The A records all point to Telnic's own web server that shows directory information,
	       A NAPTR record provides the telephone number for registrants for whom they have one.
	       Users can only directly provision MX records.
	       Except that there are 16 domains, none IDNs, that point to random other name servers and
	       mostly appear to be parked.
	    </t>
	 </section>
	 
	 <section title="TRAVEL">
	    <t>The .TRAVEL TLD has no IDNs, and no rules or practices for them.</t>
	 </section>
	 
	 <section title="XXX">
	    <t>The .XXX TLD has no IDNs, and no rules or practices for them.</t>
	 </section>
	 
      </section>
      
      <!-- delete this once the references are fixed -->
      <section title="Note about the references">
	 <t>Many of the references may appear to be incomplete.
	    This is due to bugs in the current version of XML2RFC.
	    Consult the XML for full names and URLs.
	 </t>
      </section>

   </middle>
   
   <back>
	       

      <references title="References">
	 <!-- RFCs -->
	 &RFC1034;
	 &RFC1035;
	 &RFC5890;
	 &RFC6672;
	 
	 <!-- ICANN documents -->
	 <reference anchor="G1">
	    <front><title>Guidelines for the Implementation of Internationalized Domain Names, Version 1.0</title>
	       <author fullname='ICANN'>
		  <address>
		     <uri>http://www.icann.org/en/resources/idn/idn-guidelines-20jun03-en.htm</uri>
		  </address>
	       </author>
	       <date month="June" day="20" year="2003" />
	    </front>
	 </reference>
	 
	 <reference anchor="G3">
	    <front><title>Guidelines for the Implementation of Internationalized Domain Names, Version 3.0</title>
	       <author fullname='ICANN'>
		  <address>
		     <uri>http://www.icann.org/en/resources/idn/idn-guidelines-02sep11-en.htm</uri>
		  </address>
	       </author>
	       <date month="Sept" day="02" year="2011" />
	    </front>
	 </reference>
	 
	 <reference anchor="IANAIDN">
	    <front><title>Repository of IDN Practices</title>
	       <author fullname='IANA'>
		  <address>
		     <uri>http://www.iana.org/domains/idn-tables</uri>
		  </address>
	       </author>
	       <date />
	    </front>
	 </reference>
	 
	 <reference anchor="ICANNAGREE">
	    <front><title>ICANN Registry agreements</title>
	       <author fullname='ICANN'>
		  <address>
		     <uri>http://www.icann.org/en/about/agreements/registries</uri>
		  </address>
	       </author>
	       <date />
	    </front>
	 </reference>
	 
	 <reference anchor="ICANNBIZ9">
	    <front><title>Appendix 9 of ICANN .BIZ Registry agreement</title>
	       <author fullname='ICANN'>
		  <address>
		     <uri>http://www.icann.org/en/about/agreements/registries/biz/appendix-09-08dec06-en.htm</uri>
		  </address>
	       </author>
	       <date month="Dec" year="2006" />
	    </front>
	 </reference>
	 
	 <reference anchor="ICANNCATS">
	    <front><title>Appendix S of ICANN .CAT Registry agreement</title>
	       <author fullname='ICANN'>
		  <address>
		     <uri>http://www.icann.org/en/about/agreements/registries/cat/cat-appendixs-22mar06-en.htm</uri>
		  </address>
	       </author>
	       <date month="Mar" year="2006" />
	    </front>
	 </reference>
	 
	 <reference anchor="ICANNINFO9">
	    <front><title>Appendix 9 of ICANN .INFO Registry agreement</title>
	       <author fullname='ICANN'>
		  <address>
		     <uri>http://www.icann.org/en/tlds/agreements/info/appendix-09-08dec06.htm</uri>
		  </address>
	       </author>
	       <date month="Dec" year="2006" />
	    </front>
	 </reference>
	 
	 <reference anchor="ICANNMOBIS">
	    <front><title>Appendix S of ICANN .MOBI Registry agreement</title>
	       <author fullname='ICANN'>
		  <address>
		     <uri>http://www.icann.org/en/about/agreements/registries/mobi/mobi-appendixs-23nov05-en.htm</uri>
		  </address>
	       </author>
	       <date month="Nov" year="2005" />
	    </front>
	 </reference>
	 
	 <reference anchor="ICANNNAME11">
	    <front><title>Appendix 11 of ICANN .NAME Registry agreement</title>
	       <author fullname='ICANN'>
		  <address>
		     <uri>http://www.icann.org/en/about/agreements/registries/name/appendix-11-25mar11-en.htm</uri>
		  </address>
	       </author>
	       <date month="Mar" year="2011" />
	    </front>
	 </reference>
	 
<!-- ICANN correspondence -->
	 
	 <reference anchor="LEWIS03">
	    <front><title>Letter from Ed Lewis to Paul Twomey</title>
	       <author fullname='Ed Lewis' surname="Lewis" initials="E.">
		  <address>
		     <uri>http://www.icann.org/en/news/correspondence/lewis-to-twomey-13oct03-en.htm</uri>
		  </address>
	       </author>
	       <date month="Oct" year="2003" />
	    </front>
	 </reference>
	 
	 <reference anchor="TURNER03">
	    <front><title>Letter from Ben Turner to Paul Twomey</title>
	       <author fullname='Ben Turner' surname="Turner" initials="B.">
		  <address>
		     <uri>http://www.icann.org/en/news/correspondence/turner-to-twomey-17nov03-en.htm	</uri>
		  </address>
	       </author>
	       <date month="Nov" year="2003" />
	    </front>
	 </reference>
	 
	 <reference anchor="TWOMEY03">
	    <front><title>Letter from Paul Twomey to Ram Mohan</title>
	       <author fullname='Paul Twomey' surname="Twomey" initials="P.">
		  <address>
		     <uri>http://www.icann.org/en/news/correspondence/twomey-to-mohan-19aug03-en.htm</uri>
		  </address>
	       </author>
	       <date month="Aug" year="2003" />
	    </front>
	 </reference>
	 
	 <reference anchor="TWOMEY03A">
	    <front><title>Letter from Paul Twomey to Edward Viltz</title>
	       <author fullname='Paul Twomey' surname="Twomey" initials="P.">
		  <address>
		     <uri>http://www.icann.org/en/news/correspondence/twomey-to-viltz-21oct03-en.htm</uri>
		  </address>
	       </author>
	       <date month="Oct" year="2003" />
	    </front>
	 </reference>

	 <reference anchor="TWOMEY04">
	    <front><title>Letter from Paul Twomey to Cary Karp</title>
	       <author fullname='Paul Twomey' surname="Twomey" initials="P.">
		  <address>
		     <uri>http://www.icann.org/en/news/correspondence/twomey-to-karp-20jan04-en.htm</uri>
		  </address>
	       </author>
	       <date month="Jan" year="2004" />
	    </front>
	 </reference>
	 
	 <reference anchor="TWOMEY04A">
	    <front><title>Letter from Paul Twomey to Richard Tindal</title>
	       <author fullname='Paul Twomey' surname="Twomey" initials="P.">
		  <address>
		     <uri>http://www.icann.org/en/correspondence/twomey-to-tindal-29jul04.pdf</uri>
		  </address>
	       </author>
	       <date month="July" year="2004" />
	    </front>
	 </reference>

	 <reference anchor="TWOMEY04B">
	    <front><title>Letter from Paul Twomey to Geir Rasmussen</title>
	       <author fullname='Paul Twomey' surname="Twomey" initials="P.">
		  <address>
		     <uri>http://www.icann.org/correspondence/twomey-to-rasmussen-15aug04.pdf</uri>
		  </address>
	       </author>
	       <date month="Aug" year="2004" />
	    </front>
	 </reference>
	 
	 <!-- registry documents -->

	 <reference anchor="ASIACJK">
	    <front><title>.ASIA CJK (Chinese Japanese Korean) IDN Policies</title>
	       <author fullname='ICANN'>
		  <address>
		     <uri>http://dot.asia/policies/DotAsia-CJK-IDN-Policies-COMPLETE--2011-05-04.pdf</uri>
		  </address>
	       </author>
	       <date month="May" year="2011" />
	    </front>
	 </reference>

	 <reference anchor="MUSEUMIDN">
	    <front><title>Internationalized Domain Names (IDN) in .museum - Policies and terms of use</title>
	       <author fullname='Musedoma'>
		  <address>
		     <uri>http://about.museum/idn/idnpolicy.html</uri>
		  </address>
	       </author>
	       <date month="Jan" year="2009" />
	    </front>
	 </reference>

	 <reference anchor="PIRIDN">
	    <front><title>Expanding Multi-Lingual Options in Domain Name Versatility</title>
	       <author fullname='Public Interest Registry'>
		  <address>
		     <uri>http://www.pir.org/idn</uri>
		  </address>
	       </author>
	       <date month="Jan" year="2009" />
	    </front>
	 </reference>

	 <reference anchor="TELPOLICY">
	    <front><title>.TEL Policies</title>
	       <author fullname='Telnic'>
		  <address>
		     <uri>http://www.telnic.org/policies.html</uri>
		  </address>
	       </author>
	       <date month="Jan" year="2009" />
	    </front>
	 </reference>

<reference anchor="VRSNLANG">
	    <front><title>Scripts and Languages</title>
	       <author fullname='Verisign'>
		  <address>
		     <uri>http://www.verisigninc.com/en_US/products-and-services/domain-name-services/domain-information-center/idn-resources/scripts-languages/index.xhtml</uri>
		  </address>
	       </author>
	       <date />
	    </front>
	 </reference>
	 
	 <reference anchor="VRSNCHAR">
	    <front><title>Character Variants</title>
	       <author fullname='Verisign'>
		  <address>
		     <uri>http://www.verisigninc.com/en_US/products-and-services/domain-name-services/domain-information-center/idn-resources/character-variants/index.xhtml</uri>
		  </address>
	       </author>
	       <date />
	    </front>
	 </reference>
	 
	 <reference anchor="VRSNRULES">
	    <front><title>Registration Rules</title>
	       <author fullname='Verisign'>
		  <address>
		     <uri>http://www.verisigninc.com/en_US/products-and-services/domain-name-services/domain-information-center/idn-code-points/registration-rules/index.xhtml</uri>
		  </address>
	       </author>
	       <date />
	    </front>
	 </reference>
	 
	 <reference anchor="VRSNADDL">
	    <front><title>Additional Logic</title>
	       <author fullname='Verisign'>
		  <address>
		     <uri>http://www.verisigninc.com/en_US/products-and-services/domain-name-services/domain-information-center/idn-code-points/additional-logic/index.xhtml</uri>
		  </address>
	       </author>
	       <date />
	    </front>
	 </reference>
	 
      </references>
   </back>
</rfc>
