Subject: obs-local-part

From: Graham Klyne <[email-masked]>
Date: Wed, 19 May 1999 01:04:10 +0100

I am wondering if the syntax for obs-local-part in
<draft-ietf-drums-msg-fmt-07.txt> is what was intended.  The basis for this
query is that local-part and obs-local-part do not seem to cover every
construct allowed by RFC822 for "local-part".

Specifically, I observe that the syntax for 'obs-local-part' does not allow
an address of the form <"abc"."def"@foo.com> that is allowed by RFC822.

Is this intentional?

#g
--

For reference, the syntax productions I have surveyed are listed below:

The following syntax productions are extracted from
<draft-ietf-drums-msg-fmt-07.txt>:

Section 3.4.1:
  addr-spec       =       local-part "@" domain
  local-part      =       dot-atom / quoted-string / obs-local-part

Section 3.2.4:
  atom            =       [CFWS] 1*atext [CFWS]
  dot-atom        =       [CFWS] dot-atom-text [CFWS]
  dot-atom-text   =       1*atext *("." 1*atext)

Section 4.4:
  obs-local-part  =       atom *("." atom)

The corresponding productions from RFC822 (all taken from appendix D) are:

     addr-spec   =  local-part "@" domain        ; global address
     local-part  =  word *("." word)             ; uninterpreted
     word        =  atom / quoted-string
     atom        =  1*<any CHAR except specials, SPACE and CTLs>

#g

------------
Graham Klyne
([email-masked])

---

From: Pete Resnick <[email-masked]>
Date: Wed, 19 May 1999 12:30:59 -0500

On 5/19/99 at 1:04 AM +0100, Graham Klyne wrote:

><draft-ietf-drums-msg-fmt-07.txt> is what was intended.

I'm not totally positive. This happened after Memphis. Looking back 
at Chris's meeting minutes, I'm not sure that I got it right. Here 
are the sections in question:

At 2:46 PM -0700 5/13/97 in message 
<[email-masked]> , 
Chris Newman wrote:
>* May refuse to accept: "foo".bar@baz, linear-white-space
>  between local part & domain elements?
>  Propose, no.  Propose the following litmus test:
>  How widely is it used?
>  What is the burden on implementation?
>  How many people have messed it up in the past?
>  Does changing rule simplify ...
>  ...(see slides)
>  No objections to these rules.

...and...

>* Local-part SHOULD be encoded as as quoted string or dot-atom.
>  Yes, as in current spec.

So I think I should probably make obs-local-part the same as local-part in 822:

      local-part  =  word *("." word)

Chris?

pr
-- 
Pete Resnick <mailto:[email-masked]>
Eudora Engineering - QUALCOMM Incorporated
Ph: (217)337-6377 or (619)651-4478, Fax: (619)651-1102