Subject: [Anima-signaling] ANIMA signaling design team

From: Sheng Jiang <[email-masked]>
Date: Wed, 6 May 2015 04:01:12 +0000

Hi, all,

Following our call for volunteer last week, I am happy to also announce the membership of the design team with many thanks to them for taking on this time-consuming and critical job. The charter for the design team is below.  

   Brian Carpenter (Leader & Editor,)
   Bing Liu (Editor)
   Michael Richardson
   Tom Taylor
   Laurent Ciavaglia
   Michael Behringer
   Jeferson Nobre

The design team has a separated mailing list [email-masked]. In principle, the design team discussions should be open for all ANIMA participators. People who is interested, but do not have enough time to commit, could also be able to participate and make contributions or comments. Please subscribe if you intend to actively contribute to the animal signalling work. Otherwise we recommend you to simply subscribe to the ANIMA mailing list that we will regularly update on work progress.

Charter (also at http://trac.tools.ietf.org/wg/anima/trac/wiki/Design%20Team%20Charter): 

The Anima WG charter states a requirement for discovery and negotiation mechanisms to enable closed-loop interaction between autonomic nodes. It also states the goal of developing one or more protocol specifications (or extensions to existing protocols) to achieve these goals. There is an existing draft requirements analysis, whose main points include

   - support for any type of network objective parameter;
   - discovery must support any topology and bootstrap scenario;
   - synchronize parameters with other nodes individually or by flooding;
   - negotiate parameters with other nodes;
   - always secure;
   - A simple TLV format is proposed for the protocol design. Binary or name-based discovery are proposed as alternative discovery approaches.

The purpose of the design team is to analyse these issues and recommend a combined approach to the working group, preferably in the form of one draft or a small set of coordinated drafts. The proposed approach should be suitable for use by the Autonomic Control Plane, and for other use cases including those listed in the Anima WG charter.

In preparing the recommendation, the design team will verify and update the existing requirements and understand the relevant use cases. However, documenting and solving use cases is out of scope for the design team. The design team is encouraged to develop protocol walkthroughs and an abstract API as aids to understanding. The design team is not itself expected to produce code, but ease of implementation is an important consideration.

The draft(s) should be delivered by the July 2015 IETF (2015-07-06 cutoff date).

More information can be found at:

http://trac.tools.ietf.org/wg/anima/trac/wiki/Signaling

Regards,

Toerless + Sheng

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 07 May 2015 09:53:13 +1200

Hi all,

I happen to be on a few days holiday this week so will get more active next
week. For now it would be very useful if people could look at the requirements
and issues sub-pages of http://trac.tools.ietf.org/wg/anima/trac/wiki/Signaling

Regards
   Brian