Subject: [Anima-signaling] Reminder: comments now due from all team members

From: Brian E Carpenter <[email-masked]>
Date: Fri, 22 May 2015 16:36:49 +1200

Friendly reminder: we need comments from all team members on

- the evolving requirements & issues in the wiki
http://trac.tools.ietf.org/wg/anima/trac/wiki/Signaling

- the conceptual API in the wiki

- the 04A draft at https://github.com/becarpenter/animaproto in general

Without your comments, it's hard to make progress.

Regards
   Brian Carpenter
   http://orcid.org/0000-0001-7924-6182

---

From: Jéferson Campos Nobre <[email-masked]>
Date: Fri, 22 May 2015 17:15:21 -0300

Hi Brian.
Looking at the signalling open issues, it seems that they are mostly
resolved by now. Thus, I think the open ones are:

           <t>5. Need to expand description of the minimum requirements for
            the specification of an individual discovery, synchronization or
            negotiation objective. </t>

            <t>6. Use case and protocol walkthrough. A description of
how a node starts up,
            performs discovery, and conducts negotiation and
synchronisation for a sample
            use case would help readers to understand the
applicability of this specification.
            Maybe it should be an artificial use case or maybe a
simple real one, based on
            a conceptual API. However, the authors have not yet
decided whether to have a
            separate document or have it in the protocol document. </t>

            <t>7. Cross-check against other ANIMA WG documents for
consistency and gaps.</t>

            <t>14. Do we need an unsolicited flooding mechanism for
discovery (for discovery results
            that everyone needs), to reduce scaling impact of flooding
discovery messages? (Toerless)</t>

Maybe it would be nice to maintain just the still open issues on the list.
About issue #6, I think a separate document is better.
I am reading again the docs to help in the cross-check.
Best.

Jéferson Campos Nobre
PhD Student
Computer Networks Group -  Institute of Informatics
Federal University of Rio Grande do Sul
http://www.inf.ufrgs.br/~jcnobre

On Fri, May 22, 2015 at 1:36 AM, Brian E Carpenter
<[email-masked]> wrote:
> _______________________________________________
> Anima-signaling mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima-signaling