Subject: Re: [Anima-signaling] Protocol: Name, github, -04A version for review

From: Toerless Eckert <[email-masked]>
Date: Thu, 21 May 2015 00:26:16 -0700

Brian:

As an individual, i do like nice abbreviations like GRASP. Can i
get some definitions for the "YIKES" and "GULP" protocols please ? ;-)

As a WG chair i would suggest to consider the utility benefit of a more
unique abbreviation like GDNP. Eg: Does Cisco support the protocol...

   google:  site:cisco.com GDNP
   google:  site:cisco.com GRASP

And i use Cisco as an example, because you will find a lot more 
good references for protocols in individual products than eg: for RFC numbers.

Cheers
    toerless

In-Reply-To: <CABv6xLujUmH6Zy+=PRAsrmdi+_qvPxRMQLUU8D=3T=[email-masked]>

On Mon, May 18, 2015 at 03:19:49PM -0300, Jferson Campos Nobre wrote:
> Hi Brian.
> 
> On Sun, May 17, 2015 at 5:30 PM, Brian E Carpenter
> <[email-masked]> wrote:
> > Hi,
> >
> > I've done some work on the protocol draft following recent discussions.
> > At the moment it is still called GDNP - if people are unhappy with that,
> > we could consider changing the name to GRASP (GeneRic Autonomic Signaling
> > Protocol) which is a bit more general. ("GASP" has already been used by
> > the IEEE for something else.)
> >
> > ==> Please say if you think we should change the name.
> 
> I am ok with the current name and the new one... In any case, I don't
> know who is unhappy with GDNP :)
> 
> > More substantively, I have put a "04A" version at a newly created
> > Github repository: https://github.com/becarpenter/animaproto
> >
> > I will gladly add the design team members as collaborators on that repository.
> >
> > ==> Please send me your Github ID if you have one.
> 
> My github ID is jcnobre.
> 
> > There's the latest XML file, a "frozen" text file named *-04A
> > (the next one would be *-04B, etc.) and diffs against the -03 version.
> >
> > The change log so far:
> >
> >    Tuned wording around hierarchical structure.
> >
> >    Changed "device" to "ASA" in many places.  Reformulated requirements
> >    etc. to be clear that the ASA is the customer for signaling.
> >
> >    Requirements expanded and rearranged following design team
> >    discussion.
> >
> >    Clarified that GDNP discovery must not be a prerequisite for GDNP
> >    negotiation or synchronization (resolved issue 13).
> >
> >    Specified flag bits for objective options (resolved issue 15).
> >
> >    Clarified usage of ACP vs TLS/DTLS and TCP vs UDP (resolved issues
> >    9,10,11).
> >
> >    Editorial improvements.
> >
> > Hmm. The issues list handling needs to be improved (the resolved issues
> > are now hidden in XML comments).
> >
> > ==> Please review the draft in detail and comment.
> >
> >      Brian
> >
> >
> > _______________________________________________
> > Anima-signaling mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/anima-signaling
> 
> _______________________________________________
> Anima-signaling mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima-signaling

-- 
---
Toerless Eckert, [email-masked]

---

From: Michael Richardson <[email-masked]>
Date: Thu, 21 May 2015 11:50:16 -0400

> ==> Please say if you think we should change the name.

I found GDNP hard to say, and hard to distinguish went said verbally from
DHCP and HNCP.   I don't know if GRASP is good, but I do like the idea
that it implies giving a hands-up...

(The new node is hanging off a cliff, and but it's okay, you have the
router's hand in your GRASP...)

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-