Subject: Re: [Geopriv] Radius-Geopriv: Civic vs. geospatial location information

From: "James M. Polk" <[email-masked]>
Date: Tue, 14 Dec 2004 00:13:05 -0600

Hannes

Don't forget that geospatial is mandatory to implement in PIDF-LO. Civic is 
optional.

I don't know what you want to do about consistency here.

At 10:06 AM 12/13/2004 +0100, Tschofenig Hannes wrote:
>hi all,
>
>currently the document says that civic location information MUST be
>provided. Jari proposed to change the MUST into a SHOULD.
>
>we had a discussion on this issue during the geopriv meeting and i had the
>impression that it is ok to change the MUST into a SHOULD.
>
>ciao
>hannes
>
>_______________________________________________
>Geopriv mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/geopriv

cheers,
James

                                *******************
                 Truth is not to be argued... it is to be presented

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: Jari Arkko <[email-masked]>
Date: Tue, 14 Dec 2004 08:25:12 +0200

I can easily imagine a situation where you have just one
part of the information in an easy manner. For instance,
a plain old GPS system will only give you geospatial,
whereas configuration might just give you just the civil
location.

--Jari

James M. Polk wrote:
> Hannes
> 
> Don't forget that geospatial is mandatory to implement in PIDF-LO. Civic 
> is optional.
>

---

From: "James M. Polk" <[email-masked]>
Date: Thu, 16 Dec 2004 06:19:14 -0600

Jari

Isn't that a configuration choice?

If different docs within Geopriv give a different "default" format to use, 
this might lead to interoperability issues. This is the basis for my 
concern and question below. I wasn't picking which made more sense in 
usage, but wanted ot know if this interoperability issue was thought of.

cheers,
James

                                *******************

---

From: Jari Arkko <[email-masked]>
Date: Thu, 16 Dec 2004 14:31:54 +0200

Hi James,

> If different docs within Geopriv give a different "default" format to 
> use, this might lead to interoperability issues. This is the basis for 
> my concern and question below. I wasn't picking which made more sense in 

I very much agree with you that having a different format/rules
can lead to interoperability problems, and that this is something
we should align across all Geopriv protocols and formats.

Regarding the configuration choice: yes, I believe this should
be a configuration choice. However, isn't this dictated to
a large extent by what is mandatory in the format? If geospatial
is mandatory, then presumably you have to have the data to fill
in?

In any case, I don't have a strong feeling about this. I prefer
maintaining consistency over other concerns. But the original
issue was that I could easily imagine that someone who sets up
an access point and its RADIUS might have just the civic information
but would need a special device and a visit to the location to
determine the geospatial location. If you already determined
that this is always going to be a requirement for PIDF-LO,
I'm fine with copying that to RADIUS attributes draft too.

--Jari

>>> Don't forget that geospatial is mandatory to implement in PIDF-LO. 
>>> Civic is optional.