Subject: Re: [GROW] draft-ietf-grow-simple-va

From: Robert Raszuk <[email-masked]>
Date: Tue, 01 May 2012 09:01:41 +0200

> On Monday, April 30, 2012 1:01 PM, Robert Raszuk<mailto:[email-masked]>  wrote:
>
>> Disconnect ! Simple-va does not remove routes from RIB. It suppresses
>> overlapping less specific one.
>
> quote from the draft
> ...suppress certain routes from being installed in RIB and FIB tables.
>
> If they are "suppressed from being installed in RIB"
> then they can't be used to resolve nexthops or to be redistributed.

"certain" is the key there. The default route case is a special case as 
explained in the other email.

For any other suppressed route the resolution result will be the same if 
you are resolving via less specific which by definition will not be 
suppressed.

>> However redistribution of BGP to other protocols is
>> usually not that good of an idea
>
> Redistribution of some selected BGP routes does occur.
> Not just into IGP and LDP, but also into applications.

Sure. That's why you have ability to exclude some routes from 
suppression. In fact you can apply the exact very same policy which does 
redistribution to the function which does the suppression.

Best,
R.

---

From: Shishio Tsuchiya <[email-masked]>
Date: Thu, 03 May 2012 01:46:46 +0900

Ron and Grow WG
I posted to janog/apops to get comments of this draft.
I'm not sure why operator does not express his thought to this draft,
but I believe this draft is very important for operators especially in APAC/JAPAN.

I'm always participant to Japanese operators community meeting,
and often there were the topic of internet route growth and capacity of the router on the meeting.
I would like to share with wg the information with my summary.
Dec.2006 IRS11
Kamikawa-san,Energear Communication
http://irs.ietf.to/past/docs_20061211/CEF-kawakami-20061211.pdf (Japanese)
He explained the trouble case which the internet route exceeded than default TCAM size.

Sep.2009 IRS21
Ohkubo-san,Sakura Internet
http://irs.ietf.to/wiki.cgi?action=ATTACH&page=IRS21&file=20090914%2Dirs21%2Dpost%2Epdf (Japanese)
He explained growth of the internet route and utilization of each prefix in his network.
According to his research,there is bias of traffic load,280K prefix was not used with in 290K(full route).

July.2011 JANOG28
Mashiko-san and Yoshimura-san,NTT Communications
http://www.janog.gr.jp/meeting/janog28/doc/janog28-isp-after.pdf (Japanese)
NTT Communications,OCN is the biggest ISP of Japan.
They explained utilization of FIB memory on edge and core routers,and operation of reality.
If the memory would be closed to the limitation,then they replace the router or summarize/filter of the route.
If the filtering was careless,black hole(ping-pong) would occur.

Of course memory lookup speed will improve and the router's capacity is also growing.
But both of IPv4/IPv6 internet route is growing.

I think "draft-ietf-grow-simple-va" can help these operator's issue with minimum cost.

Regards,
-Shishio

(2012/04/26 8:32), Ronald Bonica wrote:
> Folks,
> 
> One week ago, I polled the WG in an attempt to gage interest in draft-ietf-grow-simple. The following responses were posted:
> 
> - http://www.ietf.org/mail-archive/web/grow/current/msg02228.html
> - http://www.ietf.org/mail-archive/web/grow/current/msg02229.html
> 
> While these two messages are not sufficient evidence of wide community interest in this draft, they do suggest that there may be interest out there. So, I will ask the chairs to conduct another WG last call on this draft. In the last call announcement, please ask folks who want the draft to be published to speak up. Silence will be interpreted as disinterest.
> 
> Until the WG last call is complete, I will transition the draft to the AD-WATCHING state.
> 
> Ron
> 
>  > -----Original Message-----
>  > From: Ronald Bonica
>  > Sent: Wednesday, April 18, 2012 3:19 PM
>  > To: [email-masked]
>  > Subject: draft-ietf-grow-simple-va
>  >
>  > Folks,
>  >
>  > The WG has recently submitted draft-ietf-grow-simple-va-04 for
>  > publication. As part of my AD review, I looked for discussion of this
>  > draft on the mailing list. Excluding messages from internet-
>  > [email-masked] and the chairs, the following are the only messages
>  > that I see:
>  >
>  > - (Mar-17-2011) http://www.ietf.org/mail-
>  > archive/web/grow/current/msg01851.html
>  > - (Sep-20-2010) http://www.ietf.org/mail-
>  > archive/web/grow/current/msg01748.html
>  > - (Aug-23-2010) http://www.ietf.org/mail-
>  > archive/web/grow/current/msg01726.html
>  > - (Mar-01-2010) http://www.ietf.org/mail-
>  > archive/web/grow/current/msg01618.html
>  >
>  > Given that there has been no discussion of this draft for the last
>  > year, and that there was almost no discussion of this draft before
>  > that, I need to gage the degree to which the WG is still interested in
>  > it.
>  >
>  > Can anyone speak to the level of WG interest in this draft? As this is
>  > an operational WG, I am especially interested in hearing from
>  > operators. However, all views are welcomed.
>  >
>  > --------------------------
>  > Ron Bonica
>  > vcard: www.bonica.org/ron/ronbonica.vcf
>  >
> 
> _______________________________________________
> GROW mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/grow
>