Subject: RE: Browser support for request pipelining

From: Miles Sabin <[email-masked]>
Date: Fri, 21 Jan 2000 11:58:17 -0000

Patrik Winroth,
> <snip/>

Thanks, but as far as I can see you're talking about what
RFC 2616 call persistent connections.

Request pipelining presupposes a persistent connection, but
adds the following: subsequent requests are be sent before the
corresponding responses are received, ie. instead of,

  Request1
           Response1
  Request2
           Response2
  Request3
           Response3

we could have,

  Request1
  Request2
  Request3
           Response1
           Response2
           Response3

(although, clearly, if there are many requests we might expect 
the request stream to partially overlap the response stream).

So, does anyone have any info on browser support for pipelining?

Cheers,

Miles

-- 
Miles Sabin                       Cromwell Media
Internet Systems Architect        5/6 Glenthorne Mews
+44 (0)20 8817 4030               London, W6 0LJ, England
[email-masked]          http://www.cromwellmedia.com/

---

From: "Scott Lawrence" <[email-masked]>
Date: Fri, 21 Jan 2000 08:57:09 -0500

> So, does anyone have any info on browser support for pipelining?

According to "Persistent Connection Behavior of Popular Browsers" 
[1]:

  "Both Navigator and Explorer support persistent connections 
   to Web servers and proxies. However, neither supports request
   pipelining on a persistent connection."

I found that by rummaging around in the Web Characterization 
Activity area of the W3C web site [2].

[1] http://www.cs.wisc.edu/~cao/papers/persistent-connection.html

    Zhe Wang and Pei Cao
    Department of Computer Sciences
    University of Wisconsin, Madison
    1210 West Dayton Street
    Madison, WI 53706 USA
    {zhe,[email-masked]

[2] http://www.w3.org/WCA/

--
Scott Lawrence      Director of R & D        <[email-masked]>
Agranat Systems   Embedded Web Technology   http://www.agranat.com/