Subject: Re: HTTP 1.1, proxy servers, and failed connections

From: Bob Scheifler - SMI Software Development <[email-masked]>
Date: Mon, 20 May 2002 17:04:25 -0400 (EDT)

> Could you at least describe the differing behavior you are seeing
> between implementations?

Proxy-agent: Netscape-Proxy/3.52
returns 500 for ECONNREFUSED
returns 500 for unknown (no DNS entry) host

Server: Squid/2.2.STABLE5
returns 503 for ECONNREFUSED
returns 500 for unknown (no DNS entry) host

I suspect y'all have access to a broader set of proxy servers than I do.

> And while HTTP is not TCP specific, I can't see any reason why some
> header could not be invented to convey TCP specific failure information

"connection refused" and "unknown host" are not TCP-specific concepts...

- Bob

---

From: "Joris Dobbelsteen" <[email-masked]>
Date: Tue, 21 May 2002 08:51:12 +0200

Microsoft ISA Server

Connection refuseded (cannot connect to port):
HTTP/1.1 502 Proxy Error (  Connection refused )

No host found (DNS lookup failed):
HTTP/1.1 502 Proxy Error ( Host was not found. For more
	information about this event, see ISA Server Help. )

>-----Original Message-----
>From: [email-masked] 
>[mailto:[email-masked]]On
>Behalf Of Bob Scheifler - SMI Software Development
>Sent: Monday, 20 May 2002 23:04
>To: [email-masked]
>Cc: [email-masked]
>Subject: Re: HTTP 1.1, proxy servers, and failed connections
>
>