Subject: Major upgrade to the IETF Datatracker

From: IETF Chair <[email-masked]>
Date: Tue, 14 Feb 2012 14:36:51 -0500

Shortly, the IETF datatracker will go through a major change, one of the two largest since it was first deployed more than 10 years ago.  Hopefully no one will notice.

The previous major change was in 2007, when we switched the public Datatracker from Perl cgi-bin scripts to a much more modern and safe implementation based on the Django web application framework.  Very few people noticed that change at the time.

In a few days, we will transition to completely redesigned Datatracker database schema.  The new schema will better support today's needs, and we believe it will better support future enhancements.  Frankly, we outgrew the old schema some time ago.

In order to achieve a nearly unnoticeable change-over, we now invite you to try out the new Datatracker, bang on it, kick the tires, and generally see if it works as well for you as the old one.

For some additional insight, you may want to read the instructions that was given to our testers:
 http://trac.tools.ietf.org/tools/ietfdb/wiki/InstructionsForTesters

Or, you may want to just jump in and see how it works.  Either way, please report any bugs, problems, surprises, gremlins, hiccups, flaws, and so on that you discover.  Reports will receive prompt attention.  We deploy new code upgrades (if any are available) every hour. Please use this mail list to report issues:
 [email-masked]

Try out the new Datatracker, and help us make a smooth transition.  The new Datatracker is running here:
 https://trackerbeta.ietf.org/

Thank you for your assistance,
  Russ

---

From: IETF Chair <[email-masked]>
Date: Tue, 21 Feb 2012 11:54:16 -0500

Thank you for testing the new Datatracker.  You have uncovered several bugs, and they have all been fixed.

We still want to achieve a nearly unnoticeable change-over, so please make sure the Datatracker fully supports the way that you use the current Datatracker.  Unless a significant bug is discovered in the next few days, we plan to transition to the new database schema this coming weekend.

Thanks, again,
Russ

---

From: IETF Chair <[email-masked]>
Date: Fri, 24 Feb 2012 16:21:13 -0500

Thanks for all of the testing.  Several bugs were found and fixed.  At this time there are no show stopper bugs, so we will convert to the new Datatracker database this weekend.  Of course, to be prudent, we will run a complete backup before we being the database conversion.

The database conversation is scheduled to begin at 01:00 PST on Saturday, 25 February 2012.  After checking for any errors in the conversion process, the Datatracker will be pointed at the new database.  The database conversion it is expected to finish around 03:00 PST.  Expect the Datatracker to be unavailable during this two hour period, and please plan accordingly.

Hopefully, this significant Datatracker major change will go unnoticed by the whole community.

Thanks again for you help with the testing,
  Russ

---

From: IETF Chair <[email-masked]>
Date: Sat, 25 Feb 2012 13:21:50 -0500

There were a few surprises during the Datatracker database conversion that caused it to take longer than planned, but in the end the conversion was successful.

At 07:01 PST the Datatracker was switched to the converted database.  So far, everything looks good.  Of course, we are keeping an eye out to look for potential problems.

A very heartfelt thank you to Henrik Levkowetz, Ole Laursen, and Ryan Cross for their extra efforts during the conversion.

Russ