Subject: RFC 5952, the errata, and real-world usage

From: "Manfredi, Albert E" <[email-masked]>
Date: Tue, 29 May 2012 19:14:18 -0500

I'm sure that I'm remembering correctly that we had quite a few posts, back and forth, about whether or not IPv6 addresses should be represented in lower case hexadecimal. And as I recall, the WG consensus seemed to be that upper case hex was a somewhat "dated" way of showing hex, and that addresses looked better in lower case.

Next thing you know, I'm going along based on this recollection, I look up RFC 5952, and I notice there's now an "errata" associated with it. Would that errata be about some grammatical minutiae? Nope. It's specifically to switch back to upper case hex representation! The errata says MUST for uppercase use, not even SHOULD, let alone MAY.

Then I notice that Win7 uses upper case hex for physical addresses, but lower case for IPv6 addresses. And to be even more weird, the DUID for IPv6 is shown in upper case.

So my question is, what transpired after all those discussions about this subject? Has the "errata" to RFC 5952 been written but ignored? Did I just miss the discussions on the errata? Is common usage trumping any errata? In short, should I be using upper case or lower case, for IPv6 addresses?

Bert

---

From: Randy Bush <[email-masked]>
Date: Wed, 30 May 2012 09:37:29 +0900

> Next thing you know, I'm going along based on this recollection, I
> look up RFC 5952, and I notice there's now an "errata" associated with
> it. Would that errata be about some grammatical minutiae? Nope. It's
> specifically to switch back to upper case hex representation!

there is a lesson here

randy

---

From: Seiichi Kawamura <[email-masked]>
Date: Wed, 30 May 2012 10:04:04 +0900

After the errata was posted, there was a short discussion on
6man about this and comments were made that lower case was a
WG decision and it stands. My apologies for forgetting to
update the status.

Regards,
Seiichi

(2012/05/30 9:37), Randy Bush wrote:
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>

---

From: Mark Andrews <[email-masked]>
Date: Wed, 30 May 2012 11:18:07 +1000

> > specifically to switch back to upper case hex representation!

It is only "Reported".  I would say that it needs to be moved to
"Rejected". 

-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 30 May 2012 08:03:40 +0100

> It is only "Reported".  I would say that it needs to be moved to

Obviously. An erratum that attempts to reverse a clear WG consensus
that the person doesn't like is a misuse of the errata system.

   Brian

---

From: Randy Bush <[email-masked]>
Date: Wed, 30 May 2012 18:50:35 +0900

> that the person doesn't like is a misuse of the errata system.

that is not exactly what occurred.  and blame is not very interesting
anyway.  i have asked the rfced if they can do a derattum.  others migh
support this if it is questioned.

randy