Subject: [irtf-discuss] formal methods in Internet research

From: Buday Gergely <[email-masked]>
Date: Tue, 29 Jun 2021 11:06:23 +0200

Hi there,

these days formal methods play a definite role in building secure 
systems. Especially, using theorem provers to model protocols, operating 
systems and compilers.

Which of the Internet Research Task Force research groups considers this 
area for use? Or, would it be reasonable to create one solely for this?

Best

Gergely Buday

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 29 Jun 2021 11:43:44 +0100

On 29/06/2021 10:06, Buday Gergely wrote:
> area for use?

Formal methods come up in CFRG regularly.

Cheers,
S.

---

From: Colin Perkins <[email-masked]>
Date: Tue, 29 Jun 2021 14:50:41 +0100

> On 29 Jun 2021, at 11:43, Stephen Farrell <[email-masked]> wrote:
>> Which of the Internet Research Task Force research groups considers this area for use?
> 

There’s also an [email-masked] <mailto:[email-masked]> mailing list (https://www.ietf.org/mailman/listinfo/fdt <https://www.ietf.org/mailman/listinfo/fdt>) that touches on this space, and has people thinking about how formal description techniques fit within IETF and IRTF. 

Colin

-- 
Colin Perkins
https://csperkins.org/