Subject: [Jwt-reg-review] Seeking resolution to undetermined registration request

From: Brian Campbell <[email-masked]>
Date: Thu, 5 Sep 2019 14:05:52 -0600

Per the 3rd paragraph of https://tools.ietf.org/html/rfc7800#section-6 I am
bringing an undetermined JWT Confirmation Method registration request to
the attention of the IESG in hopes of finding a resolution that will allow
for draft-ietf-oauth-mtls to proceed.
https://tools.ietf.org/html/draft-ietf-oauth-mtls-17#section-9.1 has the
IANA considerations text of the request in question to register the
"x5t#S256" method.

The initial review request was sent to the jwt-reg-review list on 8/13
https://mailarchive.ietf.org/arch/msg/jwt-reg-review/AekhdRanvPl4ej3a--5uDNB46Ps
with a followup and clarification sent two days later
https://mailarchive.ietf.org/arch/msg/jwt-reg-review/EShRPGAdV1BxwNo2JiHA_OOJdyk

IANA has also made a followup inquiry to the list
https://mailarchive.ietf.org/arch/msg/jwt-reg-review/DwM94HKuuyrncRMCvN-tAtyV9CA
and there have also been some individual messages sent that don't appear in
a public archive forum.

Thank you for your attention to this matter,
Brian Campbell

-- 
_CONFIDENTIALITY NOTICE: This email may contain confidential and privileged 
material for the sole use of the intended recipient(s). Any review, use, 
distribution or disclosure by others is strictly prohibited.  If you have 
received this communication in error, please notify the sender immediately 
by e-mail and delete the message and any file attachments from your 
computer. Thank you._

---

From: Mike Jones <[email-masked]>
Date: Fri, 6 Sep 2019 08:00:45 +0000

As a designated expert for the registry, I have approved of the registration of the "x5t#S256" JWT confirmation method.

-- Mike

________________________________
From: Jwt-reg-review <[email-masked]> on behalf of Brian Campbell <bcampbell=[email-masked]>
Sent: Thursday, September 5, 2019 1:05 PM
To: The IESG <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Subject: [Jwt-reg-review] Seeking resolution to undetermined registration request

Per the 3rd paragraph of https://tools.ietf.org/html/rfc7800#section-6<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Frfc7800%23section-6&data=02%7C01%7CMichael.Jones%40microsoft.com%7C8001c90852cb4ce6a99708d7323c871f%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637033107875826075&sdata=deixW541YIFuPqqUCzCgork5GIPjW97VlP4YRRiphxM%3D&reserved=0> I am bringing an undetermined JWT Confirmation Method registration request to the attention of the IESG in hopes of finding a resolution that will allow for draft-ietf-oauth-mtls to proceed. https://tools.ietf.org/html/draft-ietf-oauth-mtls-17#section-9.1<https://tools.ietf..org/html/draft-ietf-oauth-mtls-17#section-9.1> has the IANA considerations text of the request in question to register the "x5t#S256" method.

The initial review request was sent to the jwt-reg-review list on 8/13 https://mailarchive.ietf.org/arch/msg/jwt-reg-review/AekhdRanvPl4ej3a--5uDNB46Ps<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fmsg%2Fjwt-reg-review%2FAekhdRanvPl4ej3a--5uDNB46Ps&data=02%7C01%7CMichael.Jones%40microsoft.com%7C8001c90852cb4ce6a99708d7323c871f%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637033107875826075&sdata=E3w3wUYKHR%2B3fw3H4dV7iYwrBTLKBxb9qvbQFvWAPBQ%3D&reserved=0> with a followup and clarification sent two days later https://mailarchive.ietf.org/arch/msg/jwt-reg-review/EShRPGAdV1BxwNo2JiHA_OOJdyk<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fmsg%2Fjwt-reg-review%2FEShRPGAdV1BxwNo2JiHA_OOJdyk&data=02%7C01%7CMichael.Jones%40microsoft.com%7C8001c90852cb4ce6a99708d7323c871f%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637033107875836071&sdata=g3nzm%2BaOw0s%2FoXR3W8zRMmGIPSLrZD3KCIUnFApwyuw%3D&reserved=0>

IANA has also made a followup inquiry to the list https://mailarchive.ietf.org/arch/msg/jwt-reg-review/DwM94HKuuyrncRMCvN-tAtyV9CA<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fmsg%2Fjwt-reg-review%2FDwM94HKuuyrncRMCvN-tAtyV9CA&data=02%7C01%7CMichael.Jones%40microsoft.com%7C8001c90852cb4ce6a99708d7323c871f%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637033107875836071&sdata=CRv%2F75blHqcCaiT%2Bo%2BNXoXpOIEeO86Q1GbAK2kcfBNk%3D&reserved=0> and there have also been some individual messages sent that don't appear in a public archive forum..

CONFIDENTIALITY NOTICE: This email may contain confidential and privileged material for the sole use of the intended recipient(s). Any review, use, distribution or disclosure by others is strictly prohibited..  If you have received this communication in error, please notify the sender immediately by e-mail and delete the message and any file attachments from your computer. Thank you.

---

From: Brian Campbell <[email-masked]>
Date: Fri, 6 Sep 2019 13:01:36 -0600

Thanks Mike but according to
https://www.iana.org/assignments/jwt/jwt.xhtml#confirmation-methods you are
not actually a DE for the registry in question.

As best I can discern, Hannes is the only eligible DE here.

On Fri, Sep 6, 2019 at 2:00 AM Mike Jones <Michael.Jones=
[email-masked]> wrote:

> As a designated expert for the registry, I have approved of the
> registration of the "x5t#S256" JWT confirmation method.
>
>
> -- Mike
>
>
> ------------------------------
> *From:* Jwt-reg-review <[email-masked]> on behalf of
> Brian Campbell <bcampbell=[email-masked]>
> *Sent:* Thursday, September 5, 2019 1:05 PM
> *To:* The IESG <[email-masked]>; [email-masked] <
> [email-masked]>; [email-masked] <
> [email-masked]>
> *Subject:* [Jwt-reg-review] Seeking resolution to undetermined
> registration request
>
> Per the 3rd paragraph of https://tools.ietf.org/html/rfc7800#section-6
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Frfc7800%23section-6&data=02%7C01%7CMichael.Jones%40microsoft.com%7C8001c90852cb4ce6a99708d7323c871f%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637033107875826075&sdata=deixW541YIFuPqqUCzCgork5GIPjW97VlP4YRRiphxM%3D&reserved=0>
> I am bringing an undetermined JWT Confirmation Method registration request
> to the attention of the IESG in hopes of finding a resolution that will
> allow for draft-ietf-oauth-mtls to proceed.
> https://tools.ietf.org/html/draft-ietf-oauth-mtls-17#section-9.1
> <https://tools.ietf..org/html/draft-ietf-oauth-mtls-17#section-9.1> has
> the IANA considerations text of the request in question to register the
> "x5t#S256" method.
>
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fmsg%2Fjwt-reg-review%2FAekhdRanvPl4ej3a--5uDNB46Ps&data=02%7C01%7CMichael.Jones%40microsoft.com%7C8001c90852cb4ce6a99708d7323c871f%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637033107875826075&sdata=E3w3wUYKHR%2B3fw3H4dV7iYwrBTLKBxb9qvbQFvWAPBQ%3D&reserved=0>
> <https://nam06.safelinks..protection.outlook.com/?url=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fmsg%2Fjwt-reg-review%2FEShRPGAdV1BxwNo2JiHA_OOJdyk&data=02%7C01%7CMichael.Jones%40microsoft.com%7C8001c90852cb4ce6a99708d7323c871f%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637033107875836071&sdata=g3nzm%2BaOw0s%2FoXR3W8zRMmGIPSLrZD3KCIUnFApwyuw%3D&reserved=0>
>
>
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fmsg%2Fjwt-reg-review%2FDwM94HKuuyrncRMCvN-tAtyV9CA&data=02%7C01%7CMichael.Jones%40microsoft.com%7C8001c90852cb4ce6a99708d7323c871f%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637033107875836071&sdata=CRv%2F75blHqcCaiT%2Bo%2BNXoXpOIEeO86Q1GbAK2kcfBNk%3D&reserved=0>
> a public archive forum..
> *CONFIDENTIALITY NOTICE: This email may contain confidential and
> privileged material for the sole use of the intended recipient(s). Any
> review, use, distribution or disclosure by others is strictly prohibited..
> If you have received this communication in error, please notify the sender
> immediately by e-mail and delete the message and any file attachments from
> your computer. Thank you.*
>

---

From: Roman Danyliw <[email-masked]>
Date: Fri, 6 Sep 2019 21:00:32 +0000

Exactly.  Technically the DEs are “John Bradley and Hannes Tschofenig”.  However, the wrinkle is that John is on this draft so it has to be Hannes.

Hannes: can you please take a look at this request.

Regards,
Roman

From: iesg [mailto:[email-masked]] On Behalf Of Brian Campbell
Sent: Friday, September 06, 2019 3:02 PM
To: Mike Jones <Michael.Jones=[email-masked]>
Cc: The IESG <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [Jwt-reg-review] Seeking resolution to undetermined registration request

Thanks Mike but according to https://www.iana.org/assignments/jwt/jwt.xhtml#confirmation-methods you are not actually a DE for the registry in question.

On Fri, Sep 6, 2019 at 2:00 AM Mike Jones <Michael.Jones=[email-masked]<mailto:[email-masked]>> wrote:

-- Mike

________________________________
From: Jwt-reg-review <[email-masked]<mailto:[email-masked]>> on behalf of Brian Campbell <bcampbell=[email-masked]<mailto:[email-masked]>>
Sent: Thursday, September 5, 2019 1:05 PM
To: The IESG <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: [Jwt-reg-review] Seeking resolution to undetermined registration request

Per the 3rd paragraph of https://tools.ietf.org/html/rfc7800#section-6<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Frfc7800%23section-6&data=02%7C01%7CMichael.Jones%40microsoft.com%7C8001c90852cb4ce6a99708d7323c871f%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637033107875826075&sdata=deixW541YIFuPqqUCzCgork5GIPjW97VlP4YRRiphxM%3D&reserved=0> I am bringing an undetermined JWT Confirmation Method registration request to the attention of the IESG in hopes of finding a resolution that will allow for draft-ietf-oauth-mtls to proceed. https://tools.ietf.org/html/draft-ietf-oauth-mtls-17#section-9.1<https://tools.ietf..org/html/draft-ietf-oauth-mtls-17#section-9..1> has the IANA considerations text of the request in question to register the "x5t#S256" method.

The initial review request was sent to the jwt-reg-review list on 8/13 https://mailarchive.ietf.org/arch/msg/jwt-reg-review/AekhdRanvPl4ej3a--5uDNB46Ps<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fmsg%2Fjwt-reg-review%2FAekhdRanvPl4ej3a--5uDNB46Ps&data=02%7C01%7CMichael.Jones%40microsoft.com%7C8001c90852cb4ce6a99708d7323c871f%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637033107875826075&sdata=E3w3wUYKHR%2B3fw3H4dV7iYwrBTLKBxb9qvbQFvWAPBQ%3D&reserved=0> with a followup and clarification sent two days later https://mailarchive.ietf.org/arch/msg/jwt-reg-review/EShRPGAdV1BxwNo2JiHA_OOJdyk<https://nam06.safelinks..protection.outlook.com/?url=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fmsg%2Fjwt-reg-review%2FEShRPGAdV1BxwNo2JiHA_OOJdyk&data=02%7C01%7CMichael.Jones%40microsoft.com%7C8001c90852cb4ce6a99708d7323c871f%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637033107875836071&sdata=g3nzm%2BaOw0s%2FoXR3W8zRMmGIPSLrZD3KCIUnFApwyuw%3D&reserved=0>

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 11 Sep 2019 07:02:47 +0000

I reviewed the x5t#S256 JWT Confirmation Method and I approve it.

Ciao
Hannes

From: Roman Danyliw <[email-masked]>
Sent: Freitag, 6. September 2019 23:01
To: Brian Campbell <bcampbell=[email-masked]>; Mike Jones <Michael.Jones=[email-masked]>; Hannes Tschofenig <[email-masked]>
Cc: The IESG <[email-masked]>; [email-masked]; [email-masked]
Subject: RE: [Jwt-reg-review] Seeking resolution to undetermined registration request

Regards,
Roman

From: iesg [mailto:[email-masked]] On Behalf Of Brian Campbell
Sent: Friday, September 06, 2019 3:02 PM
To: Mike Jones <Michael.Jones=[email-masked]<mailto:Michael.Jones=[email-masked]>>
Cc: The IESG <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Jwt-reg-review] Seeking resolution to undetermined registration request

-- Mike

CONFIDENTIALITY NOTICE: This email may contain confidential and privileged material for the sole use of the intended recipient(s). Any review, use, distribution or disclosure by others is strictly prohibited..  If you have received this communication in error, please notify the sender immediately by e-mail and delete the message and any file attachments from your computer. Thank you.
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.