Subject: [Ltru] Re: Pointers from registry to documentation

From: "Doug Ewell" <[email-masked]>
Date: Wed, 28 Jun 2006 09:31:14 -0700

Richard Ishida <ishida at w3 dot org> wrote:

> I have been given an action by the W3C Architecture Domain to request 
> that the language subtag registry at 
> http://www.iana.org/assignments/language-subtag-registry contain a 
> pointer to the document that explains what the field names mean.
>
> Would it be possible to include a comment at the top of the document 
> containing the URI of the spec?

Early "planning" versions of the Registry were in a 
vertical-bar-delimited format, not record-jar, and did contain a header 
comment explaining the nature of the file and describing the fields. 
When we switched to record-jar in April 2005, there was no provision for 
a file-level comment, only the "Comments:" fields that applies to 
individual records.  Around August, someone apparently proposed adding a 
file-level comment, but there was little support at the time for adding 
this.  I can't find the exact thread at the moment.

I think the general feeling was that the RFC should point to the 
Registry, not necessarily the other way around.

The LTRU Working Group could choose to reopen this topic at the time it 
revises RFC 3066bis to incorporate ISO 639-3-based subtags.

--
Doug Ewell
Fullerton, California, USA
http://users.adelphia.net/~dewell/

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Addison Phillips" <[email-masked]>
Date: Wed, 28 Jun 2006 10:07:04 -0700

> Around August, someone apparently 
> proposed adding a 
> file-level comment,

That would be me.

Lack of comments in the file is not fatal. For example, the IANA "numbers" page does point to the RFC. Presumably anyone reading the registry will be doing so for a reason. But I agree that in-file comments would be useful, especially as pointers to BCP 47.

However, my sense is that file-level comments will not be added during an RFC 3066ter effort, in an effort to do as little as possible to the file format. It might be possible to ease the restriction on the File-Date so that it can contain Comments fields. Most record-jar processors are already capable of handling multiple field records anyway...

Addison

Addison Phillips
Internationalization Architect - Yahoo! Inc.

Internationalization is an architecture.
It is not a feature.  

> -----Original Message-----
> From: Doug Ewell [mailto:[email-masked]] 
> Sent: mercredi 28 juin 2006 09:31
> To: [email-masked]; LTRU Working Group
> Subject: [Ltru] Re: Pointers from registry to documentation
>

---

From: "Addison Phillips" <[email-masked]>
Date: Wed, 28 Jun 2006 12:02:11 -0700

FWIW, the original proposal for file-level comments was made here:

http://www1.ietf.org/mail-archive/web/ltru/current/msg03286.html

The issue was tracked in the issue tracker here:

https://rt.psg.com/index.html?q=1103

And the resolution was:

---
After discussion, rough consensus was that this as a "nice to have"
rather than an essential addition, and that it was more important
to finish the WG last call and submit the draft for publication.
Consequently, this item is marked "rejected".
---

Addison Phillips

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Doug Ewell
> Subject: Re: Pointers from registry to documentation
> 
> Ietf-languages mailing list
> [email-masked]
> http://www.alvestrand.no/mailman/listinfo/ietf-languages
> 
>

---

From: "Doug Ewell" <[email-masked]>
Date: Wed, 28 Jun 2006 12:54:57 -0700

> Consequently, this item is marked "rejected".

Thanks for exhuming that.

---

From: John Cowan <[email-masked]>
Date: Wed, 28 Jun 2006 21:25:53 -0400

Addison Phillips scripsit:

> However, my sense is that file-level comments will not be added during
> an RFC 3066ter effort, in an effort to do as little as possible to
> the file format. It might be possible to ease the restriction on the
> File-Date so that it can contain Comments fields. Most record-jar
> processors are already capable of handling multiple field records
> anyway...

My objection to file-level comments is that it's not clear what
record they are in, and since we maintain the file record by record,
they would need a unique mechanism for change control.

This objection wouldn't apply to Comment: entries in the File-Date
record, though, and I'd be in favor of that.

-- 
They tried to pierce your heart                 John Cowan
with a Morgul-knife that remains in the         http://www.ccil.org/~cowan
wound.  If they had succeeded, you would
become a wraith under the domination of the Dark Lord.         --Gandalf