Subject: Re: [Ltru] Eliminating the preposterous ASCII ordering in lookup

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 23 Jun 2006 23:27:39 -0700

Hi -

Just what is the proposed change to the document?
To delete the example?  This is rather late in the process,
and, as a technical contributor, I don't see any significant
benefit to deleting the example.

Randy

----- Original Message ----- 
From: "Addison Phillips" <[email-masked]>
To: "'Mark Davis'" <[email-masked]>; "'John Cowan'" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, February 22, 2006 4:45 PM
Subject: RE: [Ltru] Eliminating the preposterous ASCII ordering in lookup

It is merely an example of what one could do. It isn't obligatory. So it isn't that bad, I guess. We don't have text that requires a
mapping to basic ranges at the moment and don't necessarily need to introduce it.

On the other hand, I don't think I'd implement an algorithm that way and most underlying locale-like fallback systems will do as I
suggested.

Addison

Addison Phillips
Internationalization Architect - Yahoo! Inc.

Internationalization is an architecture.
It is not a feature.

> -----Original Message-----
> From: Mark Davis [mailto:[email-masked]]
> Sent: 2006年2月22日 14:54
> To: John Cowan
> Cc: [email-masked]
> Subject: Re: [Ltru] Eliminating the preposterous ASCII ordering in lookup
>
> I'm guessing, but only a guess, that this is related to the following text:
>
> > For example, an implementation could return the matching content that
> > is first in ASCII-order. For example, if the language range were
> > "*-CH" and the set of content included "de-CH", "fr-CH", and "it-CH",
> > then the content labeled "de-CH" would be returned.
> "preposterous" is a overblown language. And I strongly disagree with
> your proposed change. In the example there clearly *exists* content
> matching *-CH. So returning the default content (which could be, say,
> Japanese) is clearly *not* what I would have expected!
>
> There could, of course, be other strategies for picking a single tag to
> return from lookup when there are multiple matches for a wildcard. But
> whatever example we choose should not return something so clearly
> disconnected from the user's desired outcome. And ASCII is simple to
> explain.
>
> Mark
>
> John Cowan wrote:
> > It's really laughable to suggest that implementations might use ASCII
> > tag ordering to make fallback decisions on lookup.  IMHO, the behavior
> > of extended ranges on lookup should be:
> >
> > If the first subtag of a language range is '*' and it is
> > followed by other ranges in a priority list, skip it.
> > If the first subtag is '*' and there are no following
> > ranges, return the default content.  All other '*' subtags
> > should be removed before lookup processing is done.
> >
> > That is simple, clear, to the point, straightforward, and doesn't
> provide
> > preposterous results.
> >
> >
>
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Addison Phillips" <[email-masked]>
Date: Sat, 24 Jun 2006 05:53:39 -0700

Uh... Randy...?

That mail was sent in February?

Addison

Addison Phillips

> From: Randy Presuhn [mailto:[email-masked]] 
> Sent: vendredi 23 juin 2006 23:28
> To: [email-masked]
> It is merely an example of what one could do. It isn't 
> obligatory. So it isn't that bad, I guess. We don't have text 
> that requires a
> On the other hand, I don't think I'd implement an algorithm 
> that way and most underlying locale-like fallback systems will do as I
> suggested.
> 
> Addison
> 
> Addison Phillips

---

From: "Mark Davis" <[email-masked]>
Date: Sat, 24 Jun 2006 09:48:42 -0700

I agree.

On 6/23/06, Randy Presuhn <[email-masked]> wrote:
> It is merely an example of what one could do. It isn't obligatory. So it
> isn't that bad, I guess. We don't have text that requires a
> On the other hand, I don't think I'd implement an algorithm that way and
> most underlying locale-like fallback systems will do as I
> suggested.
>
> Addison
>
> Addison Phillips

---

From: "Randy Presuhn" <[email-masked]>
Date: Sun, 25 Jun 2006 09:12:25 -0700

Hi -

Hmmm.  You're right.  I don't know why it showed up in my inbox
last Friday.  Never mind!

Randy

----- Original Message ----- 
From: "Addison Phillips" <[email-masked]>
To: "'Randy Presuhn'" <[email-masked]>; <[email-masked]>
Sent: Saturday, June 24, 2006 5:53 AM
Subject: RE: [Ltru] Eliminating the preposterous ASCII ordering in lookup

Uh... Randy...?

Addison

Addison Phillips

---

From: Martin Duerst <[email-masked]>
Date: Sun, 25 Jun 2006 21:12:59 +0900

>That mail was sent in February?

Yes indeed. We have just finished addressing all the IETF Last Call
comments. Except in the case that somebody finds a really major bug,
or unless we get some comments from IESG members, discussions on the
matching draft are closed.

Regards,   Martin.

>> Subject: RE: [Ltru] Eliminating the preposterous ASCII 

#-#-#  Martin J. Du"rst, Assoc. Professor, Aoyama Gakuin University
#-#-#  http://www.sw.it.aoyama.ac.jp       mailto:[email-masked]