Subject: [Ltru] RE: Preliminary Investigation into Application of ISO 11179

From: "Debbie Garside" <[email-masked]>
Date: Tue, 27 Jun 2006 10:27:18 +0100

CORRECTION

I wrote:

----
The IETF (or LTRU) would need to apply for an International Code Designator
(ICD) - a four integer code; this coupled with the organization name as well
as a "department" identifier (OPI) becomes the IRDI e.g. 1234.IETF.LTRU.
The ICD would be registered by the RA of ISO/IEC 6523 Organization Codes as
Registration Authority Identifier which is currently BSI. 
----

It should read:

----

The IETF (or LTRU) would need to apply for an International Code Designator
(ICD) - a four integer code; this coupled with the organization name as well
as a "department" identifier (OPI) becomes the RAI e.g. 1234.IETF.LTRU.  The
ICD would be registered by the RA of ISO/IEC 6523 Organization Codes as
Registration Authority Identifier which is currently BSI.   

----

The change is from "IRDI" to "RAI"

Debbie 

> -----Original Message-----
> From: Debbie Garside [mailto:[email-masked]] 
> Sent: 27 June 2006 09:22
> To: 'LTRU Working Group'
> Cc: 'Doug Ewell'
> Subject: Preliminary Investigation into Application of ISO 11179
> 
> Findings of a preliminary investigation into the application 
> of ISO 11179 to the RFC3066bis Registry
> 
> Cost
> Initial investigations suggest that ISO 11179 can be applied 
> to the Registry at a base level for very little cost.  The 
> main cost is in mapping the ISO 11179 terminology to the 
> existing Registry terminology and a number of additional data 
> elements would be required.  The Registry already 
> incorporates a system of metadata elements that are 
> consistent with the model presented within ISO 11179.  
> 
> In particular the value of the following aspects of ISO 
> 11179-6 should be investigated: 
> 
> Identification
> The attributes registration authority identifier (RAI), data 
> identifier (DI), and version identifier (VI) constitute the 
> international registration data identifier (IRDI). At least 
> one IRDI is required for an administered item. 
> 
> Data identifiers are assigned by a Registration Authority; 
> data identifiers shall be unique within the domain of a 
> Registration Authority. 
> 
> Requirements for a Registration Authority, and a discussion 
> of the IRDI, appear in ISO/IEC 11179-6.
> 
> As each Registration Authority may determine its own DI 
> assignment scheme, there is no guarantee that the DI by 
> itself will uniquely identify an administered item. For 
> example, if two authorities both use sequential 6-digit 
> numbers, there may be two administered items with the same 
> DI's; however, the administered items will almost certainly 
> not be the same. 
> 
> If one administered item appears in two registers, it will 
> have two DI's. Therefore, both the DI and the RAI are 
> necessary for identification of an administered item. 
> 
> If particular attributes of an administered item change, then 
> a new version of the administered item shall be created and 
> registered. The registrar shall determine these attributes. 
> In such a case, a VI is required to complete the unique 
> identification of an administered item.
> 
> For further guidance, see ISO/IEC 11179-6. 
> 
> An IRDI can serve as a key when exchanging data among 
> information systems, organizations, or other parties who wish 
> to share a specific administered item, but might not utilize 
> the same names or contexts.
>  
> ISO/IEC 11179 does not specify the format or content of a unique DI.
> 
> The IETF (or LTRU) would need to apply for an International 
> Code Designator (ICD) - a four integer code; this coupled 
> with the organization name as well as a "department" 
> identifier (OPI) becomes the IRDI e.g. 1234.IETF.LTRU.  The 
> ICD would be registered by the RA of ISO/IEC 6523 
> Organization Codes as Registration Authority Identifier which 
> is currently BSI.  
> 
> Implications for the LTRU Registry
> The DI (or UI - Unique Identifier) cannot be the Subtag as 
> there are already conflicting Subtags within the registry 
> (e.g. cy/CY).  It is more preferable that the unique 
> identifier be the chosen language/country/script name (please 
> note, this is not the preferred name).  This would fit with 
> the current ISO 639-3, -5 and -6 models and open the Registry 
> to adoption by meta-data knowledge grids. (I will take a good 
> look at the naming conventions within ISO 3166-1 at a later 
> date but prior to publication of FDIS 3166-1).  
> 
> Anomalies within ISO naming conventions of standards issued 
> prior to the adoption of ISO 11179 can be dealt with on a 
> case by case basis via set rules.   
> 
> The Subtag would become a "Representation" with the name 
> being the unique "Data Identifier". This would involve having 
> a "Primary Description" which would form the DI.
> 
> In reviewing the "Required Metadata Attributes" for a 
> "Preferred Standard" Status administered item, preliminary 
> investigations reveal no serious additional requirements 
> other than those already mentioned here. Some manipulation 
> and interpretation of registry data and standard mandatory 
> requirements would be required but no difficulties are 
> envisaged. I would refer the WG to ISO/IEC 11179-6:2005(E); 
> Table B-8 (p.34)
>  
> Benefits
> The ISO 11179 model allows for there being conflicting codes 
> between different meta-data registries in conformity with ISO 
> 11179; that is part of the conceptual model.  ("in conformity 
> with" is correct - there are essential parts of the standard).
> 
> In essence, the ISO 11179 meta-model supports linkage to 
> other ISO 11179 conformant meta-data registries thus 
> facilitating data exchange/interchange whilst giving the LTRU 
> Registry ownership of the data elements contained therein - 
> they become LTRU elements giving room for manoeuvre should 
> ISO get it wrong.
> 
> This will make language tags more meaningful in the future.  
> The key word here is "linkage".  ISO 11179 conformant 
> meta-data registries facilitate the creation of knowledge 
> grids, grid computing and the semantic web!
> 
> Conclusion
> At first glance the cost/value ratio favours ISO 11179; there 
> appears to be very little cost yet the true benefits of 
> future interoperability and data exchange are unknown.  
> 
> It is recommended that further investigation be conducted 
> before application of ISO 11179 can be discussed at WG level. 
> 
> Further benefits with regard to data interchange should be explored.
> 
> It is further recommended that the "investigation into 
> application of ISO 11179 Meta Data Registries to the Registry 
> and its registration procedures be conducted by nominated 
> members of the WG with a view to application" be added to the 
> new LTRU Charter.  
> 
> Best regards
> 
> 
> Debbie Garside
> 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Martin Duerst <[email-masked]>
Date: Wed, 28 Jun 2006 17:25:27 +0900

[co-chair hat on]
Many thanks to Debbie (and Karen) for looking into this.

[as a technical contributor]

>Registration Authority Identifier which is currently BSI.   

Regarding codes such as 1234.IETF.LTRU, I have to say that I don't
personally see the point. I very much agree that having a global
identification system is a good thing, but if we are going to use
such a system, it should use URIs (or IRIs) in order to be
compatible with Web technology. If ISO 11179 doesn't provide or
allow this, then I don't think it's worth considering (at least
not this aspect of the standard).

Regards,   Martin.

#-#-#  Martin J. Du"rst, Assoc. Professor, Aoyama Gakuin University
#-#-#  http://www.sw.it.aoyama.ac.jp       mailto:[email-masked]

---

From: "Debbie Garside" <[email-masked]>
Date: Thu, 29 Jun 2006 00:06:45 +0100

Martin wrote:

> Regarding codes such as 1234.IETF.LTRU, I have to say that I 
> don't personally see the point. I very much agree that having 
> a global identification system is a good thing, but if we are 
> going to use such a system, it should use URIs (or IRIs) in 
> order to be compatible with Web technology. If ISO 11179 
> doesn't provide or allow this, then I don't think it's worth 
> considering (at least not this aspect of the standard).

The format of these data elements is as follows:
- ICD: integer, variable length, up to 4 digits;
- Identification of an organization: variable length, up to 35 characters;
- OPI: variable length, up to 35 characters;
- OPIS: 1 character.
No particular sequence of the four components is specified (at least not in
ISO 11179).

Additionally, there are no constraints on elements that can be added!

Best regards

Debbie

> From: Martin Duerst [mailto:[email-masked]] 
> Sent: 28 June 2006 09:25
> To: Debbie Garside; 'Debbie Garside'; 'LTRU Working Group'
> Cc: 'Doug Ewell'
> Subject: Re: [Ltru] RE: Preliminary Investigation into 
> Application of ISO 11179
> 
> [co-chair hat on]
> >(ICD) - a four integer code; this coupled with the 
> organization name as 
> >well as a "department" identifier (OPI) becomes the RAI e.g. 
> >1234.IETF.LTRU.  The ICD would be registered by the RA of 
> ISO/IEC 6523 Organization Codes as
> Regarding codes such as 1234.IETF.LTRU, I have to say that I 
> don't personally see the point. I very much agree that having 
> a global identification system is a good thing, but if we are 
> going to use such a system, it should use URIs (or IRIs) in 
> order to be compatible with Web technology. If ISO 11179 
> doesn't provide or allow this, then I don't think it's worth 
> considering (at least not this aspect of the standard).
> 
> Regards,   Martin.
> 
> 
>