Subject: [manet-dlep-rg] DLEP Capabilities exchange

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Tue, 21 Jan 2014 20:18:08 +0000

Gentlemen, 

Well, sigh…  I've been frankly trying to avoid this, but it's a subject I want to breach - if not for DLEP-05, then maybe for an 06. 

I've been thinking again about some exchange of capabilities. Not for a DLEP session startup, but to cover some specific use cases. The first one I'll throw out is this: 

Consider a deployment using OSPF, over satellite. That OSPF network is defined as a standard broadcast (Ethernet) segment, with a Designated Router (DR) and a Backup DR (BDR). In the satellite implementation I'm considering, it would be a good thing if the DR was co-located with the SatCom "Network Controller". 

So, I'm thinking about a capabilities exchange, where the modem (the satcom terminal) tells the router "I'm the NC". This would, in turn, cause the connected router to be "very willing" (whatever that means) to be the DR in an OSPF election (the next election that occurs on this link)… There would also have to be an "I'm NOT the NC anymore" message that flows from modem to router if/when that function is reassigned in the network. 

I'm sure there are other cases. Let's see if we can make a run at enumerating (and hopefully "generalizing") them.

Regards,
Stan

---

From: Teco Boot <[email-masked]>
Date: Tue, 21 Jan 2014 22:47:33 +0100

Poeh, way back struggling with this.

Yes, this kind of information exchange is useful. But why would this example need negotiation? Just sending the TLV is OK, and routers can drop it or use it at own willing.

For for example a BW allocation sub protocol, I can imagine both modem and router MUST first agree before bothering each other with a "foreign DLEP sub-protocol language". The negotiation SHOULD NOT terminate the DLEP session. And can take place at any time after DLEP session setup.

The flow control and link characteristics request capabilities could be negotiated.

Teco

Op 21 jan. 2014, om 21:18 heeft Stan Ratliff (sratliff) <[email-masked]> het volgende geschreven:

> _______________________________________________
> manet-dlep-rg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet-dlep-rg

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Wed, 22 Jan 2014 14:22:07 +0000

Teco, 

Yeah, we're on the same page in that this isn't a negotiation. This is just giving the router and the modem some ways to signal the other that (for lack of a better term) "I'm special in some way" - in my case below, the satellite network is more efficient if the DR is co-located with the NC. This *could* be done with a-priori configuration, but it's easier if the NC announces itself (the NC function can, to an extent, be dynamically assigned). Please notice - I never used the word "negotiation" in the initial email… ;-) Perhaps I should have said a "Capabilities Announcement"? 

Regards,
Stan

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Wed, 22 Jan 2014 14:52:30 +0000

Yep, something like that. Or (yet another) list of enumerated TLVs that talk about "specialness"… I don't have a solid handle on how to implement, but I can see at least one case where this would be useful. 

Regards,
Stan

On Jan 22, 2014, at 9:47 AM, Henning Rogge <[email-masked]>
 wrote:

> Something like a series of (boolean?) flags that tell the other side
> of the DLEP session "hey, I can do X!" or "I am Y, please remember
> this" ?
> 
> Henning Rogge
> 
> On Wed, Jan 22, 2014 at 3:22 PM, Stan Ratliff (sratliff)
> <[email-masked]> wrote:
>> Teco,
>>

---

From: Henning Rogge <[email-masked]>
Date: Wed, 22 Jan 2014 15:47:37 +0100

Henning Rogge

---

From: Teco Boot <[email-masked]>
Date: Wed, 22 Jan 2014 17:22:31 +0100

OK, the negotiation is another, related topic. Some capabilities can be just advertised, others could indicate support of a DLEP sub-protocol. If both peers advertise the capabilities, the DLEP sub-protocol can start running.

Start using such for the flow control and link characteristics request capabilities, in dlep-06?

Teco

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Wed, 22 Jan 2014 18:17:32 +0000

On Jan 22, 2014, at 11:22 AM, Teco Boot <[email-masked]> wrote:

> OK, the negotiation is another, related topic. Some capabilities can be just advertised,

I'm good with calling this an "advertisement". 

> others could indicate support of a DLEP sub-protocol. If both peers advertise the capabilities, the DLEP sub-protocol can start running.
> 

I don't think it's necessary. 

Regards,
Stan