Subject: Re: [MIB-DOCTORS] Float32? and NHDP-MIB reviewer

From: "Bert (IETF) Wijnen" <[email-masked]>
Date: Thu, 02 Dec 2010 15:59:43 +0100

Well, if Randy wants, he could submit it to OPSAWG
Or submit it as an indivudka draft.

But in any event, it will take a while (as does virtually ervery
document in IETF).

Bert

On 12/2/10 3:35 PM, Robert G Cole wrote:
> OK, thanks.  What do you all think the timeframe is for moving
> draft-presuhn-floats-00.txt forward?
>
> Bob
>
> On Tue, 2010-11-30 at 21:47 +0100, Juergen Schoenwaelder wrote:
>> On Tue, Nov 30, 2010 at 12:43:02PM -0500, Robert G Cole wrote:
>>
>>> Thanks.  Ulrich and I are looking for a Float defined from 0 to unity.
>>> Do you believe the below representation is appropriate for our purposes?
>> We should really have clean Float types and avoid rather arbitrary
>> references between MIB modules. draft-presuhn-floats-00.txt is the
>> right way to go in general.
>>
>> If in a specific case where you only need to represent the range
>> [0..1], you might instead of a float simply use an Unsigned32 or
>> Unsigned64 to be devided by the maximum value. This way, you end up
>> getting more precision with fewer bits and without a need for floats
>> at all.
>>
>> /js
>>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 2 Dec 2010 16:16:42 +0100

> But in any event, it will take a while (as does virtually ervery

The fastest thing I have done in recent years was RFC 4789 - which
took about 6 months from the very start to publication of the RFC (and
this was an AD sponsored individual submission). The timeline can be
found here:

  https://datatracker.ietf.org/doc/draft-schoenw-snmp-ether/history/

You might save 2-3 weeks at the very beginning and another 1-2 weeks
by avoiding the summer break. I guess 5 months is pretty much what you
will need to expect - until publication.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 2 Dec 2010 08:42:38 -0800

Hi -

My most recent, the breathtakingly trivial RFC 6082, took just
short of five months, so I agree with Juergen's timeline assessment.

For purposes of re-use of these TCs, I believe it's best for the
document to be standards-track.  (Unless folks are comfortable
making normative references to "informational.")

Randy

----- Original Message ----- 
> From: "Juergen Schoenwaelder" <[email-masked]>
> To: "Bert (IETF) Wijnen" <[email-masked]>
> Cc: <[email-masked]>; "Robert G Cole" <[email-masked]>; "Ulrich Herberg" <[email-masked]>; "Juergen Quittek"
<[email-masked]>
> Sent: Thursday, December 02, 2010 7:16 AM
> Subject: Re: [MIB-DOCTORS] Float32? and NHDP-MIB reviewer
>
> _______________________________________________
> MIB-DOCTORS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mib-doctors

---

From: "Bert (IETF) Wijnen" <[email-masked]>
Date: Thu, 02 Dec 2010 22:52:47 +0100

I agree that STDs track would be best

Bert

On 12/2/10 5:42 PM, Randy Presuhn wrote:
>> From: "Juergen Schoenwaelder"<[email-masked]>
>> To: "Bert (IETF) Wijnen"<[email-masked]>
>> Cc:<[email-masked]>; "Robert G Cole"<[email-masked]>; "Ulrich Herberg"<[email-masked]>; "Juergen Quittek"
> <[email-masked]>
>> Fax:   +49 421 200 3103<http://www.jacobs-university.de/>

---

From: "Joan Cucchiara" <[email-masked]>
Date: Thu, 2 Dec 2010 17:27:33 -0500

I agree that Standard's track is best for this also.

Thanks,
  -Joan

----- Original Message ----- 
From: "Bert (IETF) Wijnen" <[email-masked]>
To: "Randy Presuhn" <[email-masked]>
Cc: <[email-masked]>; "Robert G Cole" <[email-masked]>; "Ulrich 
Herberg" <[email-masked]>; "Juergen Quittek" <[email-masked]>
Sent: Thursday, December 02, 2010 4:52 PM
Subject: Re: [MIB-DOCTORS] Float32? and NHDP-MIB reviewer

>>> Cc:<[email-masked]>; "Robert G Cole"<[email-masked]>; 
>>> "Ulrich Herberg"<[email-masked]>; "Juergen Quittek"
>> <[email-masked]>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 5 Dec 2010 12:33:52 +0100

+1 on the fact that standards track is best. 

I will do my best from where I am to make the time from start to end
shorter. This looks best fit for OPSAWG. They do not need rechartering
for this, as they are openly chartered by default to do small
incremental work. Yet, this adds a month at least as they need to ask
the 'should we take this work question?' on the list, and they need to
run an IETF LC. If you guys believe that it's super-urgent I can take it
as AD-sponsored, but I prefer not to do it. 

Dan

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Joan Cucchiara
> Sent: Friday, December 03, 2010 12:28 AM
> To: Bert (IETF) Wijnen; Randy Presuhn
> Cc: [email-masked]; Robert G Cole; Ulrich Herberg; 
> Juergen Quittek
> Cc: <[email-masked]>; "Robert G Cole" 
> <[email-masked]>; "Ulrich Herberg" 
> <[email-masked]>; "Juergen Quittek" <[email-masked]>
> >> My most recent, the breathtakingly trivial RFC 6082, took 
> just short 
> >> of five months, so I agree with Juergen's timeline assessment.
> >>
> >> document to be standards-track.  (Unless folks are 
> comfortable making 
> >> normative references to "informational.")
> >>
> >> Randy
> >>
> >>> From: "Juergen 
> Schoenwaelder"<[email-masked]>
> >>> took about 6 months from the very start to publication of the RFC 
> >>> (and this was an AD sponsored individual submission). The 
> timeline 
> >>> can be found here:
> >>>
> >>>    
> >>> by avoiding the summer break. I guess 5 months is pretty 
> much what 
> >>> you will need to expect - until publication.
> >>>
> >>> /js
> >>>
> >>> --