Subject: Re: [mile] early AD-review of draft-ietf-mile-template

From: Brian Trammell <[email-masked]>
Date: Wed, 9 May 2012 15:59:42 +0200

Hi, Sean,

Many thanks for the review; I've incorporated these points into a working -04 revision. A couple of questions or points, inline...

On Apr 26, 2012, at 9:19 PM, Sean Turner wrote:

> 12) A.8 and A.9 and I guess all appendices in this draft, should we require that they explicitly be marked as normative parts of the document?

A.8 and A.9 are weird, in that they're appendices within an appendix. Examples are definitely informative. The XML schema should be normative; however, technically, I would presume it's the schema that goes into the IANA registry (which, of course, in the normal case, gets taken from the schema in Appendix A of an extension document) which is normative.

> 13) Appendix B: Should we make up something to register as opposed to using something real? Maybe something like lottery #?

It would reduce potential confusion; we've already had appsarea feedback on this example. I did spend a little time trying to come up with an enumeration extension that was clearly ridiculous but still realistic enough to be properly illustrative; this is as close as I got. Not sure where we'd wedge a lottery number into one of the enumerations. I'm inclined to leave this as it is for now...

Best regards, 

Brian (author hat)

---

From: Sean Turner <[email-masked]>
Date: Wed, 09 May 2012 10:40:18 -0400

> A.8 and A.9 are weird, in that they're appendices within an appendix. Examples are definitely informative. The XML schema should be normative; however, technically, I would presume it's the schema…

So I guess adding a sentence in A.8/A.9 to say something like "When the 
draft is produced this Appendix should be marked as normative" and "When 
the draft is produced this Appendix should be marked as informative" 
would work for me.

> It would reduce potential confusion; we've already had appsarea feedback on this example. I did spend a little time trying to come up with an enumeration extension that was clearly ridiculous but s…

I'm fine with that.  I'm sure there's somebody out there that'll have an 
opinion on this - and then we can ask them for an example ;)

spt

---

From: Brian Trammell <[email-masked]>
Date: Wed, 9 May 2012 17:47:23 +0200

On May 9, 2012, at 4:40 PM, Sean Turner wrote:

> So I guess adding a sentence in A.8/A.9 to say something like "When the draft is produced this Appendix should be marked as normative" and "When the draft is produced this Appendix should be marked as informative" would work for me.

Okay, that makes sense. (As I've already submitted an -04, would it be okay to hold this for -05 pending other IESG commentary, presuming there's nothing else that needs to be done before then?)

Cheers,

Brian (author hat)

---

From: Sean Trner <[email-masked]>
Date: Wed, 9 May 2012 11:55:10 -0400

Absolutely.

Spt

Sent from my iPhone

---

From: <[email-masked]>
Date: Wed, 9 May 2012 17:00:14 -0400

Hello Brian,

Thank you for making all of the requested changes.  It appears all recommended changes were addressed in this WGLC.  The document is ready for IESG last call.

Thank you,
Kathleen

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Sean Trner
Sent: Wednesday, May 09, 2012 11:55 AM
To: Brian Trammell
Cc: [email-masked]
Subject: Re: [mile] early AD-review of draft-ietf-mile-template

Absolutely.

Spt

Sent from my iPhone