Subject: [pkix] [Technical Errata Reported] RFC3029 (6445)

From: RFC Errata System <[email-masked]>
Date: Fri, 26 Feb 2021 13:12:11 -0800 (PST)

The following errata report has been submitted for RFC3029,
"Internet X.509 Public Key Infrastructure Data Validation and Certification Server Protocols".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6445

--------------------------------------
Type: Technical
Reported by: Russ Housley <[email-masked]>

Section: Appendix E

Original Text
-------------
Version ::= Integer

Corrected Text
--------------
Version ::= INTEGER

Notes
-----
INTEGER must be in all capital letters for the ASN.1 Module to compile.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC3029 (draft-ietf-pkix-dcs-07)
--------------------------------------
Title               : Internet X.509 Public Key Infrastructure Data Validation and Certification Server Protocols
Publication Date    : February 2001
Author(s)           : C. Adams, P. Sylvester, M. Zolotarev, R. Zuccherato
Category            : EXPERIMENTAL
Source              : Public-Key Infrastructure (X.509)
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Russ Housley <[email-masked]>
Date: Fri, 26 Feb 2021 23:33:31 -0500

It turns out that there are other places where Integer is used in the same module, so this is a better fix:

OLD:

Version ::= Integer

NEW:

Integer ::= INTEGER

Version ::= Integer

> On Feb 26, 2021, at 4:12 PM, RFC Errata System <[email-masked]> wrote:
>