Subject: [pkix] [Technical Errata Reported] RFC3029 (6443)

From: RFC Errata System <[email-masked]>
Date: Fri, 26 Feb 2021 12:32:20 -0800 (PST)

The following errata report has been submitted for RFC3029,
"Internet X.509 Public Key Infrastructure Data Validation and Certification Server Protocols".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6443

--------------------------------------
Type: Technical
Reported by: Russ Housley <[email-masked]>

Section: Appendix E

Original Text
-------------
  ContentInfo FROM CryptographicMessageSyntax {iso(1)
  member-body(2) us(840) rsadsi(113549) pkcs(1) pkcs-9(9)
  smime(16) modules(0) cms(1)}

Corrected Text
--------------
  ContentInfo, DigestAlgorithmIdentifier
  FROM CryptographicMessageSyntax
    {iso(1) member-body(2) us(840) rsadsi(113549) pkcs(1) pkcs-9(9)
     smime(16) modules(0) cms(1)}

Notes
-----
DigestAlgorithmIdentifier is not defined in the ASN.1 Module.  The easiest fix is to IMPORT it from the CMS ASN.1 Module.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC3029 (draft-ietf-pkix-dcs-07)
--------------------------------------
Title               : Internet X.509 Public Key Infrastructure Data Validation and Certification Server Protocols
Publication Date    : February 2001
Author(s)           : C. Adams, P. Sylvester, M. Zolotarev, R. Zuccherato
Category            : EXPERIMENTAL
Source              : Public-Key Infrastructure (X.509)
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: "Paul Hoffman" <[email-masked]>
Date: Fri, 26 Feb 2021 13:31:18 -0800

I can verify that this correction is good.

--Paul Hoffman

On 26 Feb 2021, at 12:32, RFC Errata System wrote:

> DigestAlgorithmIdentifier is not defined in the ASN.1 Module.  The 
> easiest fix is to IMPORT it from the CMS ASN.1 Module.
>
> Instructions:
> -------------
> Title               : Internet X.509 Public Key Infrastructure Data 
> Validation and Certification Server Protocols

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 26 Feb 2021 13:34:13 -0800

> I can verify that this correction is good.

Thanks!  (I already marked it as Verified.)

-Ben