Subject: [Teas-ns-dt] Definitions draft text improvement on NBI/SBI.

From: Kiran Makhijani <[email-masked]>
Date: Mon, 16 Mar 2020 18:26:11 +0000

Hi,
In response to text objections about "bidirectional and asynchronous" terms being implementation specific.  Please see
https://github.com/teas-wg/teas-ns-dt/issues/14

In nutshell new text could be revised as below:

- TSC Northbound Interface (NBI): is an interface between a higher level
system, e.g. 'E2E network slice orchestrator' and the 'Transport
slice controller'. It is a technology agnostic interface. Over this NBI, slice characteristics and other requirements can be informed to TSC and current state of a transport slice can be retrieved.

- TSC Southbound Interface (SBI): is an interface between 'Transport
slice controller' and network controller(s). These interfaces are
technology-specific and can utilize many of the existing data
models such as L2SM, L3SM, VPN, etc. TSC may request network resources or retrieval of their current state.

Thanks
Kiran

---

From: Jeff Tantsura <[email-masked]>
Date: Mon, 16 Mar 2020 15:28:22 -0700

Kiran,

I don’t think the objection is valid, “bidirectional and asynchronous” defines basic characteristics and is not implementation specific.  If someone thinks otherwise please instantiate your objections.
Thanks!

Cheers,
Jeff
On Mar 16, 2020, 11:26 AM -0700, Kiran Makhijani <[email-masked]>, wrote:
> Hi,
> In response to text objections about “bidirectional and asynchronous” terms being implementation specific.  Please see
> --
> Teas-ns-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas-ns-dt

---

From: Kiran Makhijani <[email-masked]>
Date: Tue, 17 Mar 2020 00:13:24 +0000

I am ok with either text. But since the comment was raised, it made me think that when we say asynchronous and/or  bidirectional, it is a particular means of telling implementation or low level design detail. There was also a question on what should go in framework vs definitions document.

At this point we are focusing on high-level description and the interface for me corresponds to a logical channel. I have tried to take care of these 2 keywords by using “on-demand”, “retrieval”, “informed”.

Does this explanation work for you? Or any other suggestion?
Kiran

From: Jeff Tantsura <[email-masked]>
Sent: Monday, March 16, 2020 3:28 PM
To: [email-masked]; Kiran Makhijani <[email-masked]>
Subject: Re: [Teas-ns-dt] Definitions draft text improvement on NBI/SBI.

Kiran,

Cheers,
Jeff
On Mar 16, 2020, 11:26 AM -0700, Kiran Makhijani <[email-masked]<mailto:[email-masked]>>, wrote:

Hi,
In response to text objections about “bidirectional and asynchronous” terms being implementation specific.  Please see
https://github.com/teas-wg/teas-ns-dt/issues/14<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fteas-wg%2Fteas-ns-dt%2Fissues%2F14&data=02%7C01%7Ckiranm%40futurewei.com%7C11c4e1de3a1b4e6d8a0e08d7c9f97a08%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637199945645428557&sdata=lKNqkRKgUVvbwd%2Ffnf3OXLpkxggka2cQweX5fwdODcA%3D&reserved=0>

Thanks
Kiran
--
Teas-ns-dt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas-ns-dt