Subject: [Teas-ns-dt] FW: [teas-wg/teas-ns-dt] interface - bidirectional and asynchronous words too implementation specfic (#14)

From: Eric Gray <[email-masked]>
Date: Fri, 20 Mar 2020 17:55:27 +0000

Kiran,

I didn’t see any response to the message forwarded below.  Possibly this was because I sent it from my Mac, rather than my work laptop.

That was mostly because I was seeing it because of GitHub, which I mostly do on my Mac.

I any case, I am forwarding this mail in case people missed it earlier…

--
Eric

PS – If you want to use “SLO” instead of “PDU delivery guarantees” – that is fine with me…

From: Eric Gray <[email-masked]>
Sent: Friday, March 20, 2020 1:39 PM
To: Eric Gray <[email-masked]>
Subject: Fwd: [teas-wg/teas-ns-dt] interface - bidirectional and asynchronous words too implementation specfic (#14)
Importance: High

Begin forwarded message:

From: Eric Gray <[email-masked]<mailto:[email-masked]>>
Subject: Re: [teas-wg/teas-ns-dt] interface - bidirectional and asynchronous words too implementation specfic (#14)
Date: March 16, 2020 at 4:43:23 PM EDT
To: teas-wg/teas-ns-dt <[email-masked]<mailto:[email-masked]>>
Cc: teas-wg/teas-ns-dt <[email-masked]<mailto:[email-masked]>>, Subscribed <[email-masked]<mailto:[email-masked]>>

Hi Kiran.

Some suggestions below…

There should probably be a “-02” version of “draft-nsdt-teas-transport-slice-definition” at the GitHub repository, so that we can see a latest version.  This is relevant because I assume that the “-01” version posted to the ID repository is changing, and we should  use comments on the latest updated version.

I would suggest some minor changes to the definition for SBI, along the following lines:
- Change “an interface interface between” to “a logical interface that may exist between.”

Note that this requires a change to the definition of “Transport Network Controller” along similar lines, before this is complete - i.e. - something like this:

   "Transport Network Controller (or network controller” is some form of

      network infrastructure controller that offers network resources to

      a higher level entity (or management system) to be used for network

      connectivity and PDU delivery guarantees needed to (for example)

      realize a particular transport slice."

I say “some form” because - in theory at least - the “infrastructure controller” could be anything between a “super-manager” (of subordinate management systems) to a hardware adaptation layer on a device on which a controller (or part of a distributed controller) is colocated.

The following line:

      "These are existing network controllers for a specific

      technology to realize transport slices in its network."

- may be omitted as whether or not they currently exist is not absolutely established, and - where they do currently exist - they are (or were) probably not originally intended exclusively for “[realizing] transport slices.”  At the very least, this should be changed to read along the lines of:

              “These may be existing g network controllers associated with any set of specific technologies that may be adapted to the function of realizing transport slices in a network."

TSC Southbound Interface (SBI): The TSC Southbound interface is a
bidirectional and an asynchronous interface between 'Transport
slice controller' and network controller(s). These interfaces are
technology-specific and can utilize many of the existing data
models such as L2SM, L3SM, VPN, etc.
----- alternate text -----
TSC Southbound Interface (SBI): is an interface between 'Transport
slice controller' and network controller(s). These interfaces are
technology-specific and can utilize many of the existing data
models such as L2SM, L3SM, VPN, etc. TSC may request network resources or retrieval of their current state.

---

From: Kiran Makhijani <[email-masked]>
Date: Fri, 20 Mar 2020 18:26:06 +0000

Hello Eric,
I was in turn waiting for a resolution confirmation from Jeff, then address Sergio’s comment as well.
It’s not your Mac, I am slow in replying… (until I start to edit, there’s no need to create -01.)
-Kiran

From: Eric Gray <[email-masked]>
Sent: Friday, March 20, 2020 10:55 AM
To: Kiran Makhijani <[email-masked]>
Cc: [email-masked]
Subject: FW: [teas-wg/teas-ns-dt] interface - bidirectional and asynchronous words too implementation specfic (#14)
Importance: High

Kiran,

--
Eric

From: Eric Gray <[email-masked]<mailto:[email-masked]>>
Sent: Friday, March 20, 2020 1:39 PM
To: Eric Gray <[email-masked]<mailto:[email-masked]>>
Subject: Fwd: [teas-wg/teas-ns-dt] interface - bidirectional and asynchronous words too implementation specfic (#14)
Importance: High

Begin forwarded message:

Hi Kiran.

Some suggestions below…

The following line: