Subject: [Tls-reg-review] [IANA #1113784] General Request for Assignment (tls-extensiontype-values_

From: "Amanda Baber via RT" <[email-masked]>
Date: Thu, 14 Jun 2018 21:30:32 +0000

Dear TLS experts, 

We're forwarding a request for two Application-Layer Protocol Negotiation (ALPN) Protocol ID registrations on behalf of the requester, as the registry itself doesn't yet link to its new registration instructions. 

We understand that this request will undergo a three-week review before an expert contacts us to let us know whether it's been approved (whereas ordinarily if the request had not been made through us, an expert would contact us only to notify us of an approval). 

If these are approved, please provide the Identification Sequences for the new registrations. 

The link to the new registration instructions will be added to the registry pending the draft-ietf-tls-iana-registry-updates authors' approval of a draft version of the updated registries. 

***

Contact Name:
Mike Bishop

Contact Email:
[email-masked]

Type of Assignment:
Registration of "http/0.9" and "http/1.0" tokens (both protocols are defined by https://tools.ietf.org/html/rfc1945)

Registry:
Application-Layer Protocol Negotiation (ALPN) Protocol ID

Description:
These legacy protocols are used in testing and by older server implementations and these tokens are already used in certain cases. The W3C resource-timing specification uses the ALPN registry as a reference for possible protocol values, and there has been some confusion caused by the fact that these tokens aren't actually registered.

It would simplify the community's life if these tokens, already in de facto use, were actually registered and had an appropriate specification reference.

Additional Info:
http://www.iana.org/go/rfc7301

***

Best regards,

Amanda Baber
Lead IANA Services Specialist

---

From: Mike Bishop <[email-masked]>
Date: Fri, 22 Jun 2018 20:41:30 +0000

I haven't seen any follow-up e-mails regarding this.  Is there any other information required in order to add this registration?  For additional reference, https://github.com/w3c/resource-timing/issues/122 and https://bugs.chromium.org/p/chromium/issues/detail?id=780640#c6 are the issues where this gap in the registry is causing questions.

-----Original Message-----
From: Amanda Baber via RT [mailto:[email-masked]] 
Sent: Thursday, June 14, 2018 2:33 PM
To: Mike Bishop <[email-masked]>
Subject: [IANA #1113784] General Request for Assignment (tls-extensiontype-values_

Dear Mike,

Thank you for contacting us. We've sent this on to the new team of IESG-designated experts. The Application-Layer Protocol Negotiation (ALPN) Protocol IDs registry will be updated soon to include a link to recently-approved document draft-ietf-tls-iana-registry-updates, which provides new instructions for submitting registration requests for some of the TLS registries. Specifically, in the future, new requests should be sent to a mailing list (rather than IANA) for a three-week review period. The experts will then contact us if they approve a registration.

Best regards,

Amanda Baber

On Thu Jun 14 17:27:37 2018, [email-masked] wrote:
> 
> Contact Name:
> Mike Bishop
> 
> Contact Email:
> [email-masked]
> 
> Type of Assignment:
> Registration of "http/0.9" and "http/1.0" tokens (both protocols are 
> defined by https://tools.ietf.org/html/rfc1945)
> 
> Registry:
> These legacy protocols are used in testing and by older server 
> implementations and these tokens are already used in certain cases.
> The W3C resource-timing specification uses the ALPN registry as a 
> reference for possible protocol values, and there has been some 
> confusion caused by the fact that these tokens aren't actually 
> registered.
> 
> It would simplify the community's life if these tokens, already in de 
> facto use, were actually registered and had an appropriate 
> specification reference.
> 
> Additional Info:

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Sat, 23 Jun 2018 00:17:49 +0000

Hi Mike,

Our understanding is that the review period for TLS requests is three weeks:

https://tools.ietf.org/html/draft-ietf-tls-iana-registry-updates-05#section-18

I can confirm that the message below was received by the mailing list. 

Best regards,

Amanda Baber

On Fri Jun 22 20:41:55 2018, [email-masked] wrote:
> I haven't seen any follow-up e-mails regarding this.  Is there any
> other information required in order to add this registration?  For
> additional reference, https://github.com/w3c/resource-
> timing/issues/122 and
> https://bugs.chromium.org/p/chromium/issues/detail?id=780640#c6 are
> the issues where this gap in the registry is causing questions.
> 
> Thank you for contacting us. We've sent this on to the new team of
> IESG-designated experts. The Application-Layer Protocol Negotiation
> (ALPN) Protocol IDs registry will be updated soon to include a link to
> recently-approved document draft-ietf-tls-iana-registry-updates, which
> provides new instructions for submitting registration requests for
> some of the TLS registries. Specifically, in the future, new requests
> should be sent to a mailing list (rather than IANA) for a three-week
> review period. The experts will then contact us if they approve a
> registration.
> 
> Best regards,
> 
> Amanda Baber

---

From: Yoav Nir <[email-masked]>
Date: Sat, 23 Jun 2018 12:25:53 +0300

Hi, Amanda.

I haven’t seen the original email, and can’t find it in my inbox.

Anyway, the assignments seem fine to me.

Rich?  Nick?

Yoav

> On 23 Jun 2018, at 3:17, Amanda Baber via RT <[email-masked]> wrote:
> 
> Hi Mike,
> 
> _______________________________________________
> tls-reg-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls-reg-review

---

From: "Salz, Rich" <[email-masked]>
Date: Sat, 23 Jun 2018 12:25:41 +0000

I agree it's fine.

On 6/23/18, 5:26 AM, "Yoav Nir" <[email-masked]> wrote:

    Hi, Amanda.

    
    Rich?  Nick?
    
    Yoav

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Mon, 25 Jun 2018 21:26:47 +0000

Yoav and Rich,

Can you confirm that we should list RFC 1945 as the reference?

thanks,
Amanda

---

From: Yoav Nir <[email-masked]>
Date: Tue, 26 Jun 2018 01:11:09 +0300

Yes. I don’t think there’s any better reference.

> On 26 Jun 2018, at 0:26, Amanda Baber via RT <[email-masked]> wrote:
> 
> Yoav and Rich,
>

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Mon, 25 Jun 2018 22:46:25 +0000

Hi all,

We've added the following entries to the Application-Layer Protocol Negotiation (ALPN) Protocol IDs registry:

Protocol: HTTP/0.9
Identification Sequence: 0x68 0x74 0x74 0x70 0x2f 0x30 0x2e 0x39 ("http/0.9")
Reference: [RFC1945]

Protocol: HTTP/1.0
Identification Sequence: 0x68 0x74 0x74 0x70 0x2f 0x31 0x2e 0x30 ("http/1.0")
Reference: [RFC1945]

Please see
https://www.iana.org/assignments/tls-extensiontype-values

Best regards,

Amanda Baber

On Mon Jun 25 22:11:36 2018, [email-masked] wrote:
> >>> Our understanding is that the review period for TLS requests is
> >>> three
> >>> weeks:
> >>>
> >>>> (ALPN) Protocol IDs registry will be updated soon to include a
> >>>> link
> >>>> to
> >>>>> It would simplify the community's life if these tokens, already
> >>>>> in
> >>>>> de