Subject: [Tls-reg-review] Request to code point on new drafts

From: Paul Yang <[email-masked]>
Date: Fri, 16 Aug 2019 13:13:59 +0800

Hi there,

A new draft has submitted by me yesterday: https://tools.ietf.org/html/draft-yang-tls-tls13-sm-suites-00

It describes how new SM cipher suites are used in TLS1.3. There are several code points we would like to request IANA to assign. An IANA consideration section has been included in this draft. I list the detail as follow as well.
There are 4 TBD values in this draft:

CipherSuite TLS_SM4_GCM_SM3 = { TBD1, TBD1 };
CipherSuite TLS_SM4_CCM_SM3 = { TBD2, TBD2 };

SignatureScheme sm2sig_sm3 = { TBD3 };

NamedGroup curveSM2 = { TBD4 };

Note: typos found in original draft, for TBD4 should be in registry “TLS Supported Groups” instead of “TLS HashAlgorithm”. Will fix this in next version of the draft.

Please review this request, thanks.

Regards,

Paul Yang

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 19 Aug 2019 15:51:04 +0000

Are you asking for an early code-point assignment, or do you want to wait / can you wait until the document is closer to publication?

On 8/19/19, 9:25 AM, "Paul Yang" <kaishen.yy=[email-masked]> wrote:

    Hi there,

    

    

    Regards,
    
    Paul Yang

---

From: Paul Yang <[email-masked]>
Date: Mon, 19 Aug 2019 23:56:47 +0800

TBH, I don’t know the difference between an early assignment and a late one (And how will it affect the final publication).

But from the implementation point of view, I think the earlier the better. Since lots of companies/organizations in China are waiting for the IANA code-points then they can implement this in their services and products.

This can definitely bring TLSv1.3 online and can make their business complied to the SCA’s requirements at the same time. Would this make a bit of sense I think...

> On Aug 19, 2019, at 11:51 PM, Salz, Rich <[email-masked]> wrote:
> 

Regards,

Paul Yang

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 20 Aug 2019 12:32:01 +0000

An early codepoint request means the numbers are “reserved” and when the RFC gets published, they are formally assigned. This is often done for interop testing while the drafts are being written.  Something could change, but it is unlikely.  Sometimes people don’t care and they can wait until the RFC is published for the formal numbers.

So in this case, asking for “early assignment” is the thing to do.

From: Paul Yang <[email-masked]>
Date: Monday, August 19, 2019 at 11:56 AM
To: Rich Salz <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [Tls-reg-review] Request to code point on new drafts

On Aug 19, 2019, at 11:51 PM, Salz, Rich <[email-masked]<mailto:[email-masked]>> wrote:

On 8/19/19, 9:25 AM, "Paul Yang" <kaishen.yy=[email-masked]<mailto:kaishen.yy=[email-masked]>> wrote:

   Hi there,

   Regards,

   Paul Yang

Regards,

Paul Yang

---

From: Paul Yang <[email-masked]>
Date: Tue, 20 Aug 2019 21:16:15 +0800

Understood, so I am formally asking for an early code-points assignment for I-D: https://tools.ietf.org/html/draft-yang-tls-tls13-sm-suites-00

And to make it more convenient, I would like to organize some publicly available English resources of the SM algorithms here, as an additional materials to the ones referenced in the draft.

For the detailed information and direct English translations of the Chinese standards of SM algorithms, please check this URL:

https://github.com/alipay/tls13-sm-spec#chinese-algorithm-standards <https://github.com/alipay/tls13-sm-spec#chinese-algorithm-standards>

There are also some expired I-Ds describing these SM algorithms:

SM2: https://tools.ietf.org/html/draft-shen-sm2-ecdsa-02
SM3: https://tools.ietf.org/html/draft-sca-cfrg-sm3-02
SM4: https://tools.ietf.org/html/draft-ribose-cfrg-sm4-10 <https://tools.ietf.org/html/draft-ribose-cfrg-sm4-10>

Thanks!

> On Aug 20, 2019, at 8:32 PM, Salz, Rich <[email-masked]> wrote:
> 
>> On Aug 19, 2019, at 11:51 PM, Salz, Rich <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> On 8/19/19, 9:25 AM, "Paul Yang" <kaishen.yy=[email-masked] <mailto:kaishen.yy=[email-masked]>> wrote:
>> 
>>    Hi there,
>> 
>>    A new draft has submitted by me yesterday: https://tools.ietf.org/html/draft-yang-tls-tls13-sm-suites-00 <https://tools.ietf.org/html/draft-yang-tls-tls13-sm-suites-00>
>> 

Regards,

Paul Yang