Subject: [TLS] How should inability to access key revocation lists impact the TLS handshake?

From: Ryan Carboni <[email-masked]>
Date: Mon, 24 Oct 2016 11:10:19 -0700

How should inability to access key revocation lists impact the TLS
handshake, if previous public keys and/or certificate hashes are not cached?

I cannot see this in the standard. Considering that all one has to do is
DDOS a certificate authority nowadays...

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 24 Oct 2016 18:15:42 +0000

> How should inability to access key revocation lists impact the TLS handshake, if previous public keys and/or certificate hashes are not cached?

Nobody does revocation on the web, for some almost all encompassing definition of nobody.

Instead, OCSP and OCSP stapling.

> I cannot see this in the standard. Considering that all one has to do is DDOS a certificate authority nowadays...

General PKI and key lifecycle issues are, properly, not part of the TLS spec.

	/r$

---

From: Xiaoyin Liu <[email-masked]>
Date: Mon, 24 Oct 2016 19:12:28 +0000

But I think the problem is that there is no TLS alert for “revocation status inaccessible”.

Best,

Xiaoyin

From: Salz, Rich<mailto:[email-masked]>
Sent: Monday, October 24, 2016 2:15 PM
To: Ryan Carboni<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [TLS] How should inability to access key revocation lists impact the TLS handshake?

        /r$
_______________________________________________
TLS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tls

---

From: Eric Rescorla <[email-masked]>
Date: Mon, 24 Oct 2016 12:17:43 -0700

"certificate_unknown" seems like it should be fine for this

On Mon, Oct 24, 2016 at 12:12 PM, Xiaoyin Liu <[email-masked]> wrote:

> *From: *Salz, Rich <[email-masked]>
> *Sent: *Monday, October 24, 2016 2:15 PM
> *To: *Ryan Carboni <[email-masked]>; [email-masked]
> *Subject: *Re: [TLS] How should inability to access key revocation lists
> impact the TLS handshake?
>
>