Subject: [TLS] Fwd: I-D Action: draft-sandj-tls-iana-registry-updates-01.txt

From: Sean Turner <[email-masked]>
Date: Thu, 20 Oct 2016 14:15:27 -0400

All,

Joe and I submitted a revised version that merged a PR from DKG and incorporated the recommended cipher suite list that was in a.4 of draft-ietf-tls-tls13-14 (and a couple of other tweaks).

A repo for the draft can be found at:
https://github.com/seanturner/draft-sandj-tls-iana-registry-updates
PRs welcome.

A couple of things I am hoping for some input on:

1) I’d like to add something along the line of the following as a warning at the top of the cider suite registry for those that simply go to the cipher list and don’t read the RFCs:

    WARNING: Cryptographic algorithms will be broken
    or weakened over time.  Blindly implementing cipher
    suites listed here is not advised.  Implementers and
    users need to check that the cryptographic algorithms
    listed continue to provide the expected level of security.

2) draft-ietf-tls-tls13 will indicate cipher suites that are recommended for TLS1.3; remember the negotiation mechanism is different now so we’re using the same registry but the values are in the new range.  It seems like we still need to populate the recommended column for pre-1.3 from -14 A.4?

spt

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: I-D Action: draft-sandj-tls-iana-registry-updates-01.txt
> Date: October 20, 2016 at 13:04:45 EDT
> To: <[email-masked]>
> Reply-To: [email-masked]
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
>        Title           : D/TLS IANA Registry Updates
>        Authors         : Joe Salowey
>                          Sean Turner
> 	Filename        : draft-sandj-tls-iana-registry-updates-01.txt
> 	Pages           : 10
> 	Date            : 2016-10-20
> 
> Abstract:
>   This document changes the IANA registry policy for a number of
>   registries related to DTLS and TLS, renames some of the registries
>   for consistency, and adds notes to many of the registries.  As a
>   result, this document updates many RFCs (see updates header).
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-sandj-tls-iana-registry-updates/
> 
> There's also a htmlized version available at:
> https://tools.ietf.org/html/draft-sandj-tls-iana-registry-updates-01
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-sandj-tls-iana-registry-updates-01
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Martin Thomson <[email-masked]>
Date: Fri, 21 Oct 2016 10:04:12 +1100

>     listed continue to provide the expected level of security.

SGTM.  Doesn't say how to check, but I'm not sure that there is any
simple advice you could give there.

> 2) draft-ietf-tls-tls13 will indicate cipher suites that are recommended for TLS1.3; remember the negotiation mechanism is different now so we’re using the same registry but the values are in the n…

I think that TLS 1.3 should just register the small set of cipher
suites that it does and this doc can take on the other things.  What
was in -14 seems about right.

---

From: Sean Turner <[email-masked]>
Date: Thu, 20 Oct 2016 20:07:42 -0400

> On Oct 20, 2016, at 19:04, Martin Thomson <[email-masked]> wrote:
> 

PR for this can be found here:
https://github.com/seanturner/draft-sandj-tls-iana-registry-updates/pull/19

spt