Subject: Re: [TLS] PR #624: Remove Supplemental Auth from TLS 1.3

From: Sean Turner <[email-masked]>
Date: Thu, 6 Oct 2016 16:08:03 -0400

All,

It’s time to put this one to bed.  ekr’s going to put back user_mapping for Andrei/MS, but we’re going to ban/orphan the client_authz and server_authz extensions.  If it turns out that there’s some need to later unban/unorphan them, then somebody can write a draft that specifies how they’re used with TLS1.3.

spt

> On Sep 06, 2016, at 23:58, Russ Housley <[email-masked]> wrote:
> 
> I agree that client_authz and server_authz have not enjoyed much implementation.
> 
> Russ
> 
> 
> On Sep 3, 2016, at 3:54 PM, Eric Rescorla <[email-masked]> wrote:
> 
>> https://github.com/tlswg/tls13-spec/pull/624
>> 
>> We currently have code points assigned for
>> 
>>  user_mapping [RFC4681]     
>>  client_authz [RFC5878]      
>>  server_authz [RFC5878] 
>> 
>> These aren't well-specified for use in TLS 1.3 and my sense is that they
>> are barely used. Any objections to just banning them? If not, I'll merge this
>> PR end of next week.
>> 
>> -Ekr
> 
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls

---

From: Yuhong Bao <[email-masked]>
Date: Thu, 6 Oct 2016 21:10:30 +0000

Yea, I think they were controversial due to a patent by RedPhone.

________________________________
From: TLS <[email-masked]> on behalf of Sean Turner <[email-masked]>
Sent: Thursday, October 06, 2016 1:08:03 PM
To: <[email-masked]>
Subject: Re: [TLS] PR #624: Remove Supplemental Auth from TLS 1.3

All,

spt