Subject: [TLS] Zero length fragments and fragmented Alert messages

From: Hubert Kario <[email-masked]>
Date: Tue, 18 Oct 2016 12:28:46 +0200

Current draft states:

  Alert messages ({{alert-protocol}}) MUST NOT be fragmented across records.

and

  Implementations MUST NOT send zero-length fragments of Handshake or
  Alert types, even if those fragments contain padding.

But I don't see what is the expected behaviour of the side receiving such 
malformed messages.

Especially the fragmented alerts are unique in that any other message type can 
be fragmented, so no rules define how to handle incorrectly fragmented 
messages. Or at least I don't see them.
-- 
Regards,
Hubert Kario
Senior Quality Engineer, QE BaseOS Security team
Web: www.cz.redhat.com
Red Hat Czech s.r.o., Purkyňova 99/71, 612 45, Brno, Czech Republic

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 18 Oct 2016 06:56:01 -0400

"   decode_error  A message could not be decoded because some field was
      out of the specified range or the length of the message was
      incorrect. "

I suppose you could argue that:

"  This alert is used for errors where the message does
      not conform to the formal protocol syntax.  "

Rules that out, but I think I'm willing to stretch it here.

-Ekr

On Tue, Oct 18, 2016 at 6:28 AM, Hubert Kario <[email-masked]> wrote:

> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>
>