Subject: Re: [TLS] Zero-RTT Data & PSK

From: Eric Rescorla <[email-masked]>
Date: Mon, 10 Oct 2016 14:59:17 -0700

I agree with MT. Hannes, if you want to clean up the text to take into
account MT's comments, I will merge

On Sat, Sep 10, 2016 at 3:35 AM, Martin Thomson <[email-masked]>
wrote:

> On 9 September 2016 at 23:37, Hannes Tschofenig
> <[email-masked]> wrote:
> > I am wondering why I cannot use Zero-RTT with just PSK-based
> authentication
> > (without a prior ticket change).
>
> I think that you would need to bind more things to the key in that
> case, but I assume that it would be OK if you did so.  You already
> need to pair a PSK with a hash, but if you paired it with a whole
> cipher suite instead and also the ALPN (which could be null), then I
> see no reason not to permit 0-RTT for pure PSK.  (I think that cipher
> suite + ALPN is sufficient, but someone can correct me if I missed
> anything.)
>
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 11 Oct 2016 18:22:09 +0200

I gave it a try, see
https://github.com/tlswg/tls13-spec/pull/668/commits/91e5b39e5f0ce62a90effdbaf4e3c90ed0d81245

Ciao
Hannes

On 10/10/2016 11:59 PM, Eric Rescorla wrote:
> On Sat, Sep 10, 2016 at 3:35 AM, Martin Thomson
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     <[email-masked] <mailto:[email-masked]>> wrote:
>     > I am wondering why I cannot use Zero-RTT with just PSK-based authentication
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/tls>
> 
>

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 11 Oct 2016 09:23:41 -0700

This LGTM. Absent objections I will merge tomorrow

---

From: Martin Thomson <[email-masked]>
Date: Wed, 12 Oct 2016 11:24:01 +1100

I put a few minor comments on the commit.  Nothing that affects the
technical content though, it looks correct.  (Good catch on SNI, I
think that I missed that one.)

On 12 October 2016 at 03:23, Eric Rescorla <[email-masked]> wrote:
> On Tue, Oct 11, 2016 at 9:22 AM, Hannes Tschofenig