Subject: Re: [Uri-review] Request to review sieve URI scheme

From: Alexey Melnikov <[email-masked]>
Date: Mon, 01 Dec 2008 10:17:24 +0000

Hi Martin,

Martin Duerst wrote:

>I had a look at parts of it. One thing I looked through is whether it's
>clear where (percent-encoded) UTF-8 can be used; that seems to be fine.
>
>It might help the reader if the grammar rules were reordered to
>read top-down. Currently it's top-down first, but then bottom-up.
>  
>
Good point. I've reordered them.

>Another thing I noticed is that characters such as "&" and "="
>are listed as needing percent-encoding. I don't see them being
>used in the syntax, so it wouldn't be necessary to percent-encode
>them. Or are they reserved for future extensions?
>  
>
Yes. I don't have any extensions in mind yet, but I thought it would be 
better to allow for them.

Thank you,
Alexey

>Regards,    Martin.
>
>At 02:56 08/12/01, Alexey Melnikov wrote:
>  
>
>>Hi,
>>I am finishing draft-ietf-sieve-managesieve-02.txt which defines the sieve: URI scheme. So I would like to ask people to review section 3 of the draft.
>>
>>Thank you,
>>Alexey
>>    
>>

_______________________________________________
Uri-review mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/uri-review

---

From: Martin Duerst <[email-masked]>
Date: Mon, 01 Dec 2008 19:24:23 +0900

Hi Alex,

At 19:17 08/12/01, Alexey Melnikov wrote:

>Yes. I don't have any extensions in mind yet, but I thought it would be better to allow for them.

In that case, I guess it would be better to say so in a note.
The principle in URI escaping is that escaping isn't necessary
in those parts where the character doesn't take a special meaning,
so people familiar with that principle could think that it's not
really necessary to escape these.

Regards,    Martin.

>>>I am finishing draft-ietf-sieve-managesieve-02.txt which defines the sieve: URI scheme. So I would like to ask people to review section 3 of the draft.

#-#-#  Martin J. Du"rst, Assoc. Professor, Aoyama Gakuin University
#-#-#  http://www.sw.it.aoyama.ac.jp       mailto:[email-masked]

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 01 Dec 2008 11:02:45 +0000

Hi Bjoern,

Bjoern Hoehrmann wrote:

>* Alexey Melnikov wrote:
>  
>
>>I am finishing draft-ietf-sieve-managesieve-02.txt which defines the 
>>sieve: URI scheme. So I would like to ask people to review section 3 of 
>>the draft.
>>    
>>
>You have a reference [IMAP4] but it's not part of the References in the
>document. I assume this should be [IMAP4rev1].
>  
>
Thanks for spotting that. Fixed.

>You should say upfront that `authority`, `unreserved`, etc. are defined
>in STD066 and included by reference. Right now you are using authority
>without defining it, and repeat the reference multiple times.
>
Yes. I had a note at the top of the ABNF, but I guess it wasn't clear.

>There is not much point in having the sub-delims-sh and uchar rules in
>the grammar, you could just use
>
>  ochar = <pchar but not ";", "&", or "=">
>
>or the equivalent (I assume)
>
>  ochar = unreserved / pct-encoded / "!" / "$" / "'" / "(" / ")"
>                                   / "*" / "+" / ","
>                                   / ":" / "@"
>
I've deleted uchar, as it wasn't used.

>That way readers would not have to read through the comments and expand
>the rules manually.
>
>The difference between
>
>  sieve://example/script  (owner absent)
>  sieve://example//script (owner empty)
>
>should be explicitly called out somewhere. It would be better if this is
>done outside the grammar (the semantics of having an empty owner would
>also be better specified outside the grammar).
>  
>
I've added a note on that.

>I don't think comments in the grammar are a good place to re-iterate en-
>coding requirements. It would be better if you just said once that chars
>other than those explicitly allowed above must be utf-8 encoded and %xx-
>escaped to be included.
>
>When you point out facts, like that ' ' can only be included in URLs in
>its %xx encoded form, do not use RFC 2119 keywords.
>  
>
Sure.

>In the "URI scheme semantics" it would be good to include some reference
>when it refers to "the REFERRAL response code".
>  
>
Added.

>As an aside, throughout the document in registration templates, it would
>be good to have a space between To: and Subject: headers, and the body.
>  
>
Yes, I will fix that.

Thank you for your review,
Alexey