Subject: NAPTR record for urn:fdc

From: "Dave Tessman" <[email-masked]>
Date: Mon, 24 Nov 2008 15:52:01 -0800

Is it even possible to create a NAPTR DNS record (on URN.ARPA?) for the
"fdc" NID (RFC 4198) that would map the ProviderId portion of the NSS to the
URN resolution path using the http scheme and the ProviderId as the domain
name as specified in RFC 4198?

urn:fdc:<ProviderId>:<CCYY>:<Path>

Becomes

http://<ProviderId>/uri-res/N2R?<Path>

The result being that folks could type the URN into their browsers and the
appropriate resource would be returned.
 
If this is doable, what would my process be to start that rolling?

Thanks,

Dave Tessman
[email-masked]

---

From: Ted Hardie <[email-masked]>
Date: Mon, 8 Dec 2008 08:45:36 -0800

Hi Dave,
	Yes, it is possible.  The IAB is responsible for the
.ARPA domain, and they need to approve delegations under
it.  If you want fdc.urn.arpa delegated, I believe they would
be the ones to instruct IANA on it.  I've cc'ed Leslie Daigle
on this message; though she's not currently on the IAB, I
believe she was chair the last time it was done and probably
has better info on how to request it of the IAB.
				regards,
					Ted Hardie

---

From: Leslie Daigle <[email-masked]>
Date: Mon, 08 Dec 2008 15:25:32 -0500

Hi,

Yep, it's been a while.

The process for getting NAPTR material into urn.arpa is outlined in this 
RFC:

http://www.ietf.org/rfc/rfc3405.txt

It would probably be good to cc the IAB and/or IANA on any 
correspondence, as it's been a while since there was any action there.

I wasn't quite clear from the message below whether help is sought for 
formulating the NAPTR record that will be registered?

Leslie.

-- 

-------------------------------------------------------------------
"Reality:
      Yours to discover."
                                 -- ThinkingCat
Leslie Daigle
[email-masked]
-------------------------------------------------------------------

---

From: "Dave Tessman" <[email-masked]>
Date: Mon, 8 Dec 2008 14:40:41 -0800

Hi Leslie,

Yup! It has been quite a while.
Hope all is well with you and yours.

>...formulating the NAPTR record...
Yes, any help would be appreciated.

Thanks,

--Dave

-----Original Message-----
From: Leslie Daigle [mailto:[email-masked]] 
Sent: Monday, December 08, 2008 12:26 PM
To: Dave Tessman
Cc: Ted Hardie; [email-masked]
Subject: Re: NAPTR record for urn:fdc

Hi,

Yep, it's been a while.

Leslie.

--