Subject: [weirds] Call for WEIRDS Agenda items for November

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 9 Sep 2013 12:02:17 -0700

Colleagues,

It's that time again.  If you would like to make a presentation to WEIRDS
when we convene in November, or if you would like to request that someone
cover a specific topic, please email [email-masked] with your
topic and requested time.  We need some idea of how long the meeting will
be so we can request an appropriate time slot.  As I said in Berlin, we
will be more liberal with the amount of time we request since we seem to
consistently run out of time, but we still need some idea in advance of
what the agenda will look like so we can be sure major subject areas are
covered.

The deadline for us to request a time slot is only a few weeks away, so
please don't leave your requests until the last minute.

Thanks!

-MSK, WEIRDS co-chair

---

From: Simon Perreault <[email-masked]>
Date: Tue, 10 Sep 2013 10:19:37 +0200

Le 2013-09-09 21:02, Murray S. Kucherawy a écrit :
> It's that time again.  If you would like to make a presentation to
> WEIRDS when we convene in November, or if you would like to request that
> someone cover a specific topic, please email
> [email-masked] <mailto:[email-masked]> with
> your topic and requested time.

Please allow some time for feedback from the interop test that is going
to take place on Saturday.

What we need time for is discussion of interop issues that result from
bugs in the specs. Those are of interest to the WG. And by definition
they are unknown to any of us until we actually do the interop test. In
Berlin we found three such issues, and ~15 minutes would have been good.
So 15 minutes in Vancouver would be a good guess.

Thanks,
Simon

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Fri, 13 Sep 2013 11:35:54 +0000

Andy and I would like to have a few minutes to talk about Unicode, normalization, and searching.

Scott

From: [email-masked] [mailto:[email-masked]] On Behalf Of Murray S. Kucherawy
Sent: Monday, September 09, 2013 3:02 PM
To: [email-masked]
Subject: [weirds] Call for WEIRDS Agenda items for November

Colleagues,

It's that time again.  If you would like to make a presentation to WEIRDS when we convene in November, or if you would like to request that someone cover a specific topic, please email [email-masked]<mailto:[email-masked]> with your topic and requested time.  We need some idea of how long the meeting will be so we can request an appropriate time slot.  As I said in Berlin, we will be more liberal with the amount of time we request since we seem to consistently run out of time, but we still need some idea in advance of what the agenda will look like so we can be sure major subject areas are covered.

The deadline for us to request a time slot is only a few weeks away, so please don't leave your requests until the last minute.

Thanks!
-MSK, WEIRDS co-chair

---

From: Carlos Martinez-Cagnazzo <[email-masked]>
Date: Thu, 19 Sep 2013 10:48:16 -0300

Dear Chairs,

I'd like to ask you to consider requesting webex/ meetecho for the weirds
session, if that would be possible at all.

cheers!

~Carlos

On Mon, Sep 9, 2013 at 4:02 PM, Murray S. Kucherawy <[email-masked]>wrote:

> cover a specific topic, please email [email-masked] with
> your topic and requested time.  We need some idea of how long the meeting
> will be so we can request an appropriate time slot.  As I said in Berlin,
> we will be more liberal with the amount of time we request since we seem to
> _______________________________________________
> weirds mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/weirds
>
>

-- 
--
=========================
Carlos M. Martinez-Cagnazzo
h <http://cagnazzo.name>ttp://cagnazzo.me
=========================

---

From: Ning Kong <[email-masked]>
Date: Tue, 24 Sep 2013 00:41:35 +0800

Hi Murray and all,

If possible, I'd like to request 10 or 15 minutes to talk about the backward compatibility of RDAP for Port 43 Whois.

The reason why I want to raise this issue is,
#1  There is a requirement from ICANN's RFP (Request for Proposal) for an Open-Source Reference Implementation of a RESTful-based Domain Name Registration Data Access Protocol.
2.4.4. The reference implementation should also include a PORT 43 WHOIS server proxy. The proxy server should be able accept client queries that conforms to RFC 3912, with the parameters as dictated by the gTLD registry / registrar policies. The proxy will translate port 43 WHOIS queries into RESTful queries, query the RESTful RDAP Service, and return the plain text results via PORT 43 back to clients.

#2  There are many users, especially the registrars, who are accustomed to the Port 43 Whois. It seems that there may be a not-short transition period from Port 43 Whois to RDAP in the near future. How to attract more users to RDAP and make this transition period transparent and steady? I think this is a question worthy of consideration by the WG. IMHO, It maybe makes sense that RDAP can be compatible with the existing Port 43 Whois, and Port 43 Whois can be updated as a RDAP client.

If the WG is interested in this question, I think the following detailed issues need to be discussed.

#1  Query format of Port 43 Whois

The common Port 43 Whois query commands are as follows,
whois -h rdap.restfulwhois.org ip
whois -h rdap.restfulwhois.org domain

Do we need to define new query parameters for Port 43 Whois based on RDAP query document?
For example:
whois -h rdap.restfulwhois.org -as 1223
whois -h rdap.restfulwhois.org -ns ns1.google.com
whois -h rdap.restfulwhois.org -entity apnic

#2  Response format of Port 43 Whois
How to return RDAP responses in JSON format via Port 43 back to Whois clients? Do we need to standardize the way to translate the JSON into plain text format or define another new response format for Port 43 Whois clients?

#3 Authentication
Http basic/digest authentication mechanism is not suitable for Port 43 Whois. Should we consider to provide authentication functions to Port 43 Whois clients?

#4 Redirect
Should we consider to provide Redirect functions to Port 43 Whois clients? If so, how?

#5 Search
Should we consider to provide Search functions to Port 43 Whois clients? If so, how?

I'm not sure whether I go astray. If so, save me please ;-)

Cheers,
Ning

> Colleagues,
> 
> It's that time again.  If you would like to make a presentation to WEIRDS when we convene in November, or if you would like to request that someone cover a specific topic, please email [email-masked] with your topic and requested time.  We need some idea of how long the meeting will be so we can request an appropriate time slot.  As I said in Berlin, we will be more liberal with the amount of time we request since we seem to consistently run out of time, but we still need some idea in advance of what the agenda will look like so we can be sure major subject areas are covered.
>

---

From: "John Levine" <[email-masked]>
Date: 24 Sep 2013 00:44:46 -0000

>If the WG is interested in this question, I think the following detailed issues need to be discussed.

It's worth talking about, if only to be sure we understand the
differences between what a WEIRDS port 43 proxy will provide, and what
the various ICANN gTLD contrcats say, and to decide whether we care.

The details of WHOIS in the different contracts are somewhat
incompatible, so either ICANN should agree that the differences don't
matter, or else you're going to have to add a whole bunch of nitpicky
backward compatibility options, for which (if I were you) I'd ask for
an amended contract to cover the extra development effort.

R's,
John

---

From: Ning Kong <[email-masked]>
Date: Tue, 24 Sep 2013 10:45:13 +0800

Hi John,

Thanks for your feedback.

> matter,
Even if ICANN don't care about the differences among current WHOIS implementations, if either ICANN or the WG think it's necessary to standardize a PORT 43 WHOIS server proxy in RDAP, I suggest we should have a slot to discuss this issue.

> or else you're going to have to add a whole bunch of nitpicky
You should tell us earlier ;-)

Cheers,
Ning

---

From: "Linlin Zhou" <[email-masked]>
Date: Mon, 30 Sep 2013 14:51:53 +0800

Dear all,

I'd like to ask for a 10 minutes slot to talk about object inventory.
First, show some updates about RIR object inventory. Second, discuss about
the extension possibility of Whois query and response. Maybe I'll send a
detailed agenda later.

Regards,

Linlin

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Murray S. Kucherawy
Sent: Tuesday, September 10, 2013 3:02 AM
To: [email-masked]
Subject: [weirds] Call for WEIRDS Agenda items for November

Colleagues,

It's that time again.  If you would like to make a presentation to WEIRDS
when we convene in November, or if you would like to request that someone
cover a specific topic, please email [email-masked] with your
topic and requested time.  We need some idea of how long the meeting will be
so we can request an appropriate time slot.  As I said in Berlin, we will be
more liberal with the amount of time we request since we seem to
consistently run out of time, but we still need some idea in advance of what
the agenda will look like so we can be sure major subject areas are covered.

Thanks!

-MSK, WEIRDS co-chair