Subject: Re: Chat comments for the record...

From: Gorry Fairhurst <[email-masked]>
Date: Fri, 1 Apr 2022 09:11:50 +0100

I think It is really good to include things repeated at the Mic, where the whole WG might hear them. I have experienced cases where the chat has diverged in parallel with meeting activities and in some cases rather disruptively...  These threads seem better placed for WG mailing list discussion, rather than a minute of a meeting?

Best wishes,
Gorry

> On 31 Mar 2022, at 19:15, Toerless Eckert <[email-masked]> wrote:
> 
> One thing coming to mind as maybe a useful idea for the next IETFs
> (aka wondering what others think):
> 
> There is often useful jabber/chat discussion during WG meetings
> (and even more so interims). And merging those comments into meeting
> notes can often be a pain. And therefore often does not happen
> (i did, but then again, we had very little jabber chat).
> 
> Given how nowadays meeting participants are even more expected to have
> computer in front of them, i wonder if it would not make sense to 
> suggest to the WG participants to directly write suggestions that they
> would like to be on the record (when they cannot/wantnot make them
> on the microphone), not (only) into the chat, but directly
> into the notes.ietf.org notes as they are being taken. And of
> course suggest to prefix any such line added with name of contributor
> e.g.:
> 
> (toerless) I really think rfc7996 is a regression bug wrt. non-support for PNG in PDF
> 
> 
> Cheers
>    Toerless

---

From: Eliot Lear <[email-masked]>
Date: Fri, 1 Apr 2022 11:37:56 +0200

> I think It is really good to include things repeated at the Mic, where the whole WG might hear them. I have experienced cases where the chat has diverged in parallel with meeting activities and in…

Yes, it can be disruptive, but during the RFC Future Directions Program 
often that was where the real work got done (and I'm saying this as the 
person who chaired the meeting).

Eliot

---

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Fri, 1 Apr 2022 11:59:21 +0200

Hi,

>> I think It is really good to include things repeated at the Mic, where
>> the whole WG might hear them. I have experienced cases where the chat
>> has diverged in parallel with meeting activities and in some cases
>> rather disruptively...  These threads seem better placed for WG mailing
>> list discussion, rather than a minute of a meeting?
>

In 6lo, actually induced by our great minute-taker (Dominique Barthel), we
have recently adopted the habit of including the chat log as part of the
minutes.

(We only include the relevant part of it, that is, we exclude jokes or
whatever that is not relevant to the WG discussions.)

Cheers,

Carles

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 1 Apr 2022 17:00:31 +0200

On Thu, Mar 31, 2022 at 06:12:39PM -0400, Joel M. Halpern wrote:
> Minutes are not intended as a capture of the full content of the discussion
> that took place.

> They are to capture highlights and most importantly
> tentative decisions and action points.

Right. So you need to make a good judgement call whether what you add to the
notes is something that reader of the notes would like to read, e.g.:
salient point, not absorbed by the outcome of any furthre discussion.

As in: No harm done IMHO if a bit too much is written into the notes because
stuff that is not relevant anymore when the notes are finalized after the
meeting is easier deleted, than something that wasn't captured being remembered
(without re-spending 2 hours watching the recording).

> So while I can understand someone wanting to put a suggestion into the
> minutes for the record I am not sure what it will accomplish.  If you want
> the Wg to pay attention to the suggestion, sending an email to the list has
> better reach, better visibility, and aligns with the goals.

Actually, i am not sure if this is always the case. The process of using
slots in WG meetings with audio and jabber channel and notes editing in the
end is a more thorough process of trying to create another stepping stone for
specific work items than just any mailing list conversation. Both have pro's and con's.

Cheers
     Toerless

> With apologies if I misunderstood the point,
> Joel
> 
> On 3/31/2022 5:32 PM, Carsten Bormann wrote:
> > On 2022-03-31, at 20:14, Toerless Eckert <[email-masked]> wrote:
> > > 
> > > into the notes.ietf.org notes as they are being taken.
> > 
> > That is such a great idea that we have been doing this in interims, design team meetings etc. for quite a while now.
> > 
> > I sometimes do that when touristing in WGs where I’m not as familiar with the current customs; this may seem a bit jarring to people who think that a minutes document cannot contain things that haven’t been said.
> > 
> > So it would be good to make this part of the etiquette, and maybe develop a notation convention for things that have not (yet) been said.  In particular, people who are going to make a comment at the microphone might want to write up their comment in the notes before that so the note-takers don’t have to do this in real-time.
> > 
> > Grüße, Carsten
> > 

-- 
---
[email-masked]

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri, 1 Apr 2022 10:04:43 -0500

Top-posting to say that I agree a lot with Carsten here.

I try not to be a note-taker these days (because I'm just not as good at it
as I used to be), but I remember taking notes on "what was going on in the
meeting" while watching the discussion in chat/jabber and thinking "that's
where the real discussion is happening".

It's likely that different people will have different experiences with
this, based on participation in different working groups, but I've been in
meetings where someone was presenting in the meeting, and discussion on
aspects of that presentation was still taking place 15 minutes later in
chat/jabber. So, in the meetings where I hang out, merging based on
timestamps doesn't work, because we're two presentations out of sync
between the meeting and the chat/jabber.

I think that's especially likely for BOFs and side meetings (and, yes, I've
offered my own working group's jabber logs as a place to exchange thoughts
for an unrelated side meeting - my working group wasn't using it at the
time, and rarely if ever does).

I applaud the dedication of chairs and secretaries who go to the effort of
cleaning up the chat/jabber conversations for inclusion in the minutes, but
at their best, some chat/jabber conversations are WELL worth including,
even in raw form.

IMO, of course. Do The Right Thing.

Best,

Spencer

On Thu, Mar 31, 2022 at 4:34 PM Carsten Bormann <[email-masked]> wrote:

> That is such a great idea that we have been doing this in interims, design
> team meetings etc. for quite a while now.
>
> I sometimes do that when touristing in WGs where I’m not as familiar with
> the current customs; this may seem a bit jarring to people who think that a
> minutes document cannot contain things that haven’t been said.
>
> So it would be good to make this part of the etiquette, and maybe develop
> a notation convention for things that have not (yet) been said.  In
> particular, people who are going to make a comment at the microphone might
> want to write up their comment in the notes before that so the note-takers
> don’t have to do this in real-time.
>
> Grüße, Carsten
>
>

---

From: Bob Hinden <[email-masked]>
Date: Fri, 1 Apr 2022 08:34:43 -0700

I don’t support some kind of automatic merging of the jabber/chat log into the minutes.   There can be a lot of noise and off topic discussion there.   For example, here is the one for the 6MAN session:

   https://jabber.ietf.org/jabber/logs/6man/2022-03-22.html

A very low signal to noise ratio.

For 6MAN, our minute takers, Peng Shuping and Pascal Thubert (many thanks to them), include on topic excerpts from the jabber log.  For example from the published minutes:

    From jabber:

	• Loba Olopade: I prefer the normal/exception terminology to fast/slow path

The session video recording and jabber log are retained and are available to anyone who wanted to look at them. I don’t think they should be automatically added to the minutes.

Bob

> On Apr 1, 2022, at 8:04 AM, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> I try not to be a note-taker these days (because I'm just not as good at it as I used to be), but I remember taking notes on "what was going on in the meeting" while watching the discussion in chat/jabber and thinking "that's where the real discussion is happening".
> 
> It's likely that different people will have different experiences with this, based on participation in different working groups, but I've been in meetings where someone was presenting in the meeting, and discussion on aspects of that presentation was still taking place 15 minutes later in chat/jabber. So, in the meetings where I hang out, merging based on timestamps doesn't work, because we're two presentations out of sync between the meeting and the chat/jabber.
> 
> I think that's especially likely for BOFs and side meetings (and, yes, I've offered my own working group's jabber logs as a place to exchange thoughts for an unrelated side meeting - my working group wasn't using it at the time, and rarely if ever does).
> 
> I applaud the dedication of chairs and secretaries who go to the effort of cleaning up the chat/jabber conversations for inclusion in the minutes, but at their best, some chat/jabber conversations are WELL worth including, even in raw form.
>

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 1 Apr 2022 18:56:51 +0200

Agreed for not automating or blind merge.

If we don't manually merge or (as i am suggesting) ask for contributors
to add notes-worthy contributions directly to the log, then maybe at miniminum
one may want to include the URL to the jabber log of the meeting day into
the notes with just the comment that the jabber log _may_ contain additional
relevant contributions. And thats just because it seems that even the existance
of chat/jabber logs seem to be a surprise to quite a few IETF participants.

Cheers
   Toerless

-- 
---
[email-masked]

---

From: Bob Hinden <[email-masked]>
Date: Fri, 1 Apr 2022 10:08:49 -0700

> On Apr 1, 2022, at 9:56 AM, Toerless Eckert <[email-masked]> wrote:
> 

I like that!

Bob

---

From: Gorry Fairhurst <[email-masked]>
Date: Fri, 1 Apr 2022 18:10:48 +0100

>> of chat/jabber logs seem to be a surprise to quite a few IETF participants.

+1, seems helpful.

Gorry

---

From: Mark Nottingham <[email-masked]>
Date: Sat, 2 Apr 2022 12:41:54 +1100

FWIW -

In the W3C, it's common to take minutes in IRC, with a bot collecting them. The bot knows who the scribe is, so it can separate out the 'official' minutes but still intersperse the chatter; it works pretty well.

See, e.g. (chosen somewhat randomly),
  https://www.w3.org/2022/03/22-ag-minutes
  https://w3c-ccg.github.io/meetings/2022-03-15-vcapi/

Cheers,

> On 2 Apr 2022, at 4:10 am, Gorry Fairhurst <[email-masked]> wrote:
> 

--
Mark Nottingham   https://www.mnot.net/